Skip to end of metadata
Go to start of metadata

System  and Hardware Requirements

The HELiOS Client can either be installed as 32-Bit or 64-Bit application. The minimum requirement is as follows:

 HELiOS 2018HELiOS 2017HELiOS 2016
Proczessor (CPU)X86 or AMD64 Architecture with SSE2 Support Main memory 
Main memory Additionally at least 2 GB main memory
Hard disk Additionally at least 2 GB free hard disk memory
Operating systemMicrosoft Windows 7 or Microsoft Windows Server 2008 R2 or higher

Please note

  • When coupling HELiOS Clients with other applications, for instance with a CAD system or Office product, please consider the minimum requirements of each system manufacturer, too.
  • When using integrated viewer, the hardware requirements of respective viewer manufacturer should be considered
  • Before commissioning HELiOS Client, you need HELiOS Database Server (cf. Fehler! Verweisquelle konnte nicht gefunden werden.) as well as a respective configurated ODBC connection. 

 


Compatibility Matrix for Coupled Applications

The overview of interfaces available for HELiOS Client is indicated below:

 

CAD systemsHELiOS 2018HELiOS 2017HELiOS 2016
HiCAD 2018
HiCAD 2017
HiCAD 2016
HiCAD 2015
HiCAD 2014
HiCAD 2013 and older
    
AutoCAD 2019(as of SP2)
AutoCAD 2018(as of SP1)
AutoCAD 2017(as of SP2)
AutoCAD 2016
AutoCAD 2015
AutoCAD 2014
AutoCAD 2013
AutoCAD 2012
AutoCAD 2011 and older
    
Inventor 2019(as of SP1)
Inventor 2018(as of SP1)
Inventor 2017(as of SP2)
Inventor 2016
Inventor 2015
Inventor 2014
Inventor 2013
Inventor 2012
Inventor 2011 and older
    
Navisworks 2015 - 2019(as of SP1)
    
SOLIDWORKS 2019(as of SP2) 
SOLIDWORKS 2018(as of SP2)
SOLIDWORKS 2017
SOLIDWORKS 2016
SOLIDWORKS 2015
SOLIDWORKS 2014
SOLIDWORKS 2013
SOLIDWORKS 2012
SOLIDWORKS 2011 and older
CAE-SystemeHELiOS 2018HELiOS 2017HELiOS 2016
EPLAN Electronic P8 Version 2.7(as of SP2)
EPLAN Electronic P8 Version 2.6
EPLAN Electronic P8 Version 2.5
EPLAN Electronic P8 Version 2.4(as of SP1)
MS Office HELiOS 2018HELiOS 2017HELiOS 2016
Office 2016
Office 2013
Office 2010
Office 2007 and older

The   symbol does not always mean that the product is not compatible. It can also mean that interactions have not been tested by the ISD.