Online Help

Videos in Help
When using the local Help with the Internet Explorer, difficulties with the playing of videos may occur. To correct this, select Internet options, open the Advanced tab, scroll down to the Security section and activate the Allow active content to run in files on My Computer checkbox.

Supported browsers
The Online Help has been successfully tested for the following browser versions:

- Internet Explorer 11.0.9600.18015, 10, 9
- Firefox 41.0.1
- Google Chrome 46.0.2490.71 m
- Safari 5.1.7

Search in Help (October 2015)
You also have the option to use Boolean operators for the searches in the Help:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Alternative</th>
<th>Effect</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>AND</td>
<td>+ or &amp;</td>
<td>Searches for topics containing all entered words</td>
<td>Sheet + Plate + Beam</td>
</tr>
<tr>
<td>OR</td>
<td></td>
<td>Searches for topics containing one of the entered words</td>
<td>Sheet</td>
</tr>
<tr>
<td>NOT</td>
<td>!</td>
<td>Searches for topics not containing the entered word</td>
<td>! Beam</td>
</tr>
<tr>
<td>( )</td>
<td></td>
<td>Combination of operators; for instance, if you enter</td>
<td>Sheet + (Plate</td>
</tr>
</tbody>
</table>

Furthermore, you can search for terms in the form of search phrases. These must be included in " ", e.g.

"the corresponding .VAA file"

Delete browser cache
After updating to a new Major Release or a Service Pack we recommend deleting the cache of your browser prior to the first calling of the Online Help.

Indication of function paths in the Help
Please note that in the HiCAD Help (both local and on the Web) you can find the exact path to a function below the topic title or below the title of a function description.
The function path helps you find the described function in HiCAD. For example, the **Double-sided offset with end caps** function (see screenshot below) can be found on the **Sketch** tab, in the pull-down menu of the **Offset** function in the **Derive** function group.

Further information on **How to use the Help** can be found in the same-named topic of the Help.

**Saving of Favorites in the Help**

Until Version 2013 (Webhelp Format) it was possible to save selected pages of the Help as Favorites (Bookmarks) by clicking the

However, these were saved as cookies and were no longer available after the deletion of the cookies. Since the switching of the Help to HTML 5 (as of Version 2014) this function is no longer available. Use the functions of your browser instead if you want to save any topics as Favorites.

**Local Help and Internet Explorer 11 (NL 7/2013)**

If you use the local version of the HiCAD or HELIOS Help (docu folder of your HiCAD 2013 or HELIOS 2013 Installation), it may occur that only empty frames instead of the start page are displayed. Downloadable files for the elimination of this problem are available at [Product know how > Documentation](http://example.com).

**Search in Online Help**

During searching through the Online Help, please note the following:

- Punctuation marks, such as full stop, colon, semicolon, comma and hyphen will be ignored.
- If you want to retrieve a file name, e.g. ALGPAR.DAT, please use the operator AND (ALGPAR AND DAT).

**Problems starting the Online Help**

Occasionally, it can happen that only the start page of the Online Help is displayed when you call the Help, while the other pages of the HiCAD Help cannot be accessed. This problem can occur when you use the ISD Wiki and the Online Help simultaneously, and then close the Wiki while leaving the Help open. If the problem occurs, click Logout on the start page of the Help, then log in again.

We will try to eliminate this problem as quickly as possible and inform you as soon as we have solved it.

**General**

**Visibility of hatchings (October 2017)**

HiCAD offers the following hatching options for cut surfaces in sectional views, detail views and cut-outs (Drawing > Properties > Attr.):
Acc to material catalogue

If a material has been assigned to a part, and a particular hatching exists for this material, (e.g. an aluminium alloy), this hatching will be used for the cut surfaces. This is the default setting, which can be changed in the Configuration Editor, at Drawing > Views > Cut surface hatching.

Parallel lines

Ignores material hatchings that may exist, and uses the settings of the view for line spacings and angles for the hatching instead.

An exact representation of hatchings is only provided in the representation modes Hidden Line dashed and Glass model. In all other cases a simplified representation of hatchings will be shown, i.e. lines are always continuous and have the same spacing.

ICN - No database / no read permission (July 2017)

The symbol is displayed if a matching database does not exist or if the logged-on user has no read permission.

Example:

Silent Installation – Redistributables (April 2017)

The Redistributables packages can be installed with `passive/norestart`. Otherwise, a reboot would be initiated automatically. If a package requires a reboot, the return value is 3010; otherwise it is 0 or an error code.

Extensive information about the silent installation can be found in the "Installation Notes" guide.

FILEGRUP.DAT - Integration of shared networks (March 2017)

If directories are accessed from more than one workstation, no local path should be entered in the filegrup.dat at C (for the “Szenen” directory), but the full UNC path as shown below:

C:\servername\sharename\directory

(...and NOT: C:F:\directory, if F: is a drive link to a share name or a network name)

Favourites Management (January 2017)

For various functions you can save all settings in the dialogue as favourites and reuse them at any time. Functions supporting the Favourites Management include:

- Staircase Configurator (Civil Engineering functions in Steel Engineering),
- Railing Configurator (Civil Engineering functions in Steel Engineering)
- Blank parameters (Sheet Metal),
- Settings for 3-D fits tables (3-D Dimensioning) and
- Part filter (on the transparent toolbar)

To open the Manage favourites dialogue, click the
symbol in the dialogue and choose the same-named function in the displayed context menu.

Favourites are saved to the same-named sub-folder of the directory in which the HiCAD Configuration database is also located. If you have installed HiCAD from the red DVD with the ISD default settings, this will be the folder `ProgramData\ISD Software und Systeme\HiCAD nnnn`, with `nnnn` being the HiCAD version, e.g. 2017.

For each functional area you have saved as a favourite a corresponding sub-folder will be created in the FAVOURITES folder, e.g. `SteelEngineering\STAIRCASEconfigurator` for the Staircase Configurator in Steel Engineering.

Click [here](#) for further information

### ICN Symbols (December 2016)

### Locked parts

**Article master locked**

This symbol is displayed if the processing of a part is not allowed because its article master is has been locked (i.e. the Workflow status does not allow writing). To prevent a processing of a part due to a locked article master, open the Configuration Editor, select System settings > Referencing and activate the checkbox for the parameter Lock parts against processing if HELiOS article master is locked. The checkbox is deactivated by default.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Article master locked" /></td>
<td>Article master locked</td>
</tr>
</tbody>
</table>

**Part checkup**

This symbol is displayed if the article master has not been released, but is still locked because the user has no permission to modify this article master. For example, this case can occur when working with the “Management + BIM” module while the Workflow status is “Checkup”; or if the current user has no permission to change this article master, whereas other users have this permission. (as of HiCAD 2016 SP2)

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Part checkup" /></td>
<td>Part checkup</td>
</tr>
</tbody>
</table>

### Meaning of the ICN Symbols

- Scale-dependency of 3-D hatchings (December 2016)
  - Use the
function to specify for 3-D hatchings whether they should be scale-dependent or scale-independent.

The default setting is **Scale-independent**. With this setting, the spacing between the hatching lines will always be the same, no matter which scale was selected.

If you want the hatching line spacing to be scaled together with the object in case of scale changes, choose the setting **Scale-dependent**.

The default setting shown in the dialogue window can be changed in the Configuration Editor, at **System settings > Visualisation > Scale dependent 3-D hatching**. (as of HiCAD 2016 SP1)

(1) Scale-dependent, (2) Scale-independent

Important Notes on Updates (November 2016)
When you run the tool **Computer Parameter Configurator** (*HiCAD.exe\ParKonfigComp.exe*) – either during installation (**Extended Settings > User Configuration tab**) or later – various system files in the **HiCAD sys directory** will be replaced (without any further query!) with the files supplied in the **HiCAD templates directory** which have been designed especially for a working with the selected module and the activated checkboxes (e.g. DSTV or Management + BIM). These files include, for example:

- HiCAD masks for the part attributes (*.HDX),
- HELIOS masks for projects, documents and articles (*.MSK),
- Various configuration files (*.HDB) and
- Template files for annotations (*.FTD).

You should therefore always make backups of all files that you have customized before using the **ParKonfigComp.exe** tool! If you have any questions, please contact your nearest ISD branch office.

**Load/Save files (June 2016)**

The Load/Save dialogue in **HiCAD 2016** has been largely adjusted to Windows 10 standards. One outstanding feature is the option to save frequently used folders in a **Quick access** section: To do this, mark the desired folder and click the symbol next to the address bar. You can also right-click the folder and select **Pin folder to Quick access**.

[Image of file management dialogue]

Click [here](#) for a detailed description of the function.

**The News Window (March 2016)**

In order that you can take full advantage of the numerous new features and enhancements offered by **HiCAD 2016**, check out the videos explaining the new and changed **HiCAD functionalities**. From now on we will provide you with such videos with each Major Release and Service Pack to keep you constantly informed in the best possible way.
You can configure the display of the News window at the bottom left. We recommend using the **Show most recent news** option to ensure that you will never miss any news about HiCAD.

You can call the News window again at any time and change the display option by clicking on the “?” symbol at the top right and selecting **Show News**.

**Please note:**

To suppress the ‘News’ window (HiCAD 2016 and higher) on the Client computers in the case of a use on a network (i.e. to achieve a behaviour as if the user had chosen Never show him-/herself), the Administrator must copy the file HiCADNews.Settings.XML to the %APPDATA%\ISD Software und Systeme\HiCAD 2016\GUI\News directory of the Client computers. In line 4 of the XML file, the Value needs to be set to 2:

```xml
<Property Name="ShowOnStartup" Type="ISDDepot.XMLFileDepotRoomType" Value="2" />
```

**Part search function with user-defined filters (Jan. 2016)**

The **Find** function

on the transparent toolbar (as of HiCAD 2002.1) provides you with an efficient and user-friendly tool for the filtering of parts and assemblies in the 3-D part structure for a wide range of individual criteria and rules. For example, you can search only for sheets of a particular material and with a thickness between 1 and 5 mm. The filter settings can be saved, marked as Favourites, and re-used at any time.

**Data backup: Deletion of unneeded files (Dec. 2015)**

As of Version 2015, the Clear **temporary directory** checkbox will no longer be there when you close HiCAD. In the TEMP subdirectory of HiCAD, all files with the exception of the auto-saved files will now automatically be deleted. These automatically saved files should be cleaned up regularly, i.e. old and unneeded backup files should be deleted regularly. In this way you ensure that the data in the TEMP directory will not consume too much space, and thus prevent a possible performance decrease of HiCAD.
Quick access to the part attributes via double click

Double click on a part and quickly access to the part attributes mask is being given.

Keyboard button 1 and 2 - Show active part / all parts

Use the keyboard buttons

1

and

2

on your standard keyboard (not the numeric keypad) to switch between the display of the active part and all parts.

- Select a part.
- Press keyboard button 1 and HiCAD only displays the active part.
- Press keyboard button 2 and HiCAD displays all parts.

Select superordinate part

To select a superordinate part in the drawing:

1. Left-click the part and keep the left mouse button pressed down.
2. Then press the right mouse button as well. HiCAD then searches for the next superordinate part and highlights it.
3. By pressing the right mouse button once more, you can continue the search, if necessary.

Save – Preview options for HELiOS and Viewer (April 2015)

When you save a drawing, you have now the option to specify the scope of previews for the representation of HiCAD drawings in HELiOS or the HiCAD Viewer. For this purpose, use the Preview options for HELiOS and Viewer functions at Drawing > Save
Please note the following:

- When you save in the SZX format, the drawing sheets of all sheet areas will always be saved. In this way, all drawing sheets can be shown in the HiCAD Viewer and also in HELiOS.
- If you use the `Save as` function you can define the scope in the dialogue window. The presetting can be defined in the Configuration Editor, at `System settings > Load/Save > Scope of representation for HELiOS preview and HiCAD Viewer`.
- If you open and edit a SZA file that was created with a version older than HiCAD 2015 (2000.0), the preview scope will be automatically set to `Active sheet` when you save. This means that only the sheet that was active during saving will be shown in HELiOS and in the Viewer. If you want to change the preview scope to `All sheets`, use the `Save with preview, All sheets` function.
- If you save a drawing that was created with HiCAD 2015 (2000.0) or higher, the preview scope that was last selected for this file will be used when you save. If you want to change the scope, use the functions of the `Save – Preview options for HELiOS and Viewer` menu.

**Filters in structure lists (February 2015)**

In structure lists, filters in the Report Manager have only effect on the uppermost level of the structure. Otherwise, the structure could not be displayed in a reasonable way. In cases where the structure is irrelevant and a structureless result would be sufficient, you can use the `Quantity list`.
Colours of Coordinate System

For the representation of the X-, Y- and Z-axes of the coordinate system, the colours specified as "Special colours" in the Colour Editor will be used. To change the settings, open the Colour Editor

(Drawing > Others), activate the Special colours tab and select the desired colours for the axes.

Moving the Coordinate System symbol

Did you know that you could move the Coordinate System symbol by pressing the CTRL+K keys. You can position the symbol anywhere on your design area. HiCAD will remember the position after restart.

Observe origin when changing drawing frames (NL12/2012)

Since HiCAD 2012 SP2 (Version 1702) the fitting point for drawing frame insertion is always located in the centre of the drawing frame - to be more precise, in the intersection point of the diagonal above the title block.
If you want to create your own, customer-specific drawing frames, or want to modify existing drawing frames, please make sure that the fitting point is located in the origin (A 0 0) before you save the new/changed drawing frame. Otherwise it may happen that the drawing frame (where the origin is relevant) will be inserted at an unwanted position far away from the cursor.

Sorting in the ICN (NL 7/2012)

In the line

Sort ICN display 2D/3D

of the system file ALGPAR.DAT you can set that the interactively callable sorting in the ICN will be active by default (the first value applies to 2-D, the second for 3-D). If you use the setting "1" HiCAD sorts by the values shown in the ICN; in case of values >1 it is also possible to sort according to a non-displayed attribute that has been specified in the system file BRW_2DSORT.HDB, or BRW_3DSORT.HDB, respectively.

Transfer of MS Excel tables to HiCAD (NL 4/2012)

To transfer contents of Excel tables to HiCAD, proceed as follows:

- In Excel, copy the desired content to the clipboard.
- In HiCAD, call the Paste from clipboard menu via the shortcut <Ctrl><V>.
- Select Excel CSV table to paste the data from the clipboard to HiCAD.
- The table will be attached as a 2-D part to the cursor can be dropped at the desired position in the drawing.

Please note: Tables pasted to HiCAD will not be updated if the data are changed in Excel.

Change the order of the Ribbon tabs (NL 2/2010)

If desired, you can change the order of the Ribbon tabs (in HiCAD 2010 or newer versions) which is defined in the system file RIBBONSLIST.TXT in the HiCAD sub-directory \WINDOWSRIBBONS. Each line in the file represents one tab. The order of the lines determines the order of the tabs on the Ribbon. We recommend that you create a backup of the file before editing it.

Please note that shortened views are not possible for shaded OpenGL representations. If you use HiCAD 2010 (SP1) or a newer version, an appropriate message will be issued. You can then decide how to proceed further. For instance, you can change the type of representation and immediately continue the function. In older HiCAD versions you needed to change the type of representation first, and then call the shortening function again.

Restore HiCAD User Interface to default (NL 3/2010)

To restore the entire HiCAD User Interface to default, proceed as follows:

- End HiCAD.
- Start the Windows Registry Editor.
- Depending on your operating system, select Start > Run, and enter regedit.
- Create a backup copy of the HiCAD 2010 directory at Hkey_current_user > Software > ISD Software und Systeme. Then delete the ....HiCAD10 directory.
- End the Registry Editor.
- Re-start HiCAD.

Processing drawing details with the mouse (NL 4/2009)
Use the mouse buttons to move and zoom drawing details:

- **Zoom drawing details** Place the cursor on the drawing surface, press and hold down the left mouse button. Now draw a rectangle for the new drawing detail.
- **Scroll drawing details** Use the mouse wheel (= middle mouse button) for scrolling.
- **Move graphic area (from Version 2009 on)** Press and hold down the CTRL key and the middle mouse button. If you now move the mouse, the entire graphic area is moved. The same effect has a simultaneous pressing and holding down of the left and the middle mouse button.
- **Dynamic zoom** Press and hold down the SHIFT key and the middle mouse button. If you now move the mouse, the drawing detail is enlarged/downsized.

**Colour Management (NL 1/2009)**

Since version 2008, HiCAD has featured new Colour Management, which distinguishes between drawing colours and system colours. Drawing colours are saved with the drawing, i.e. directly in the SZA file. By this means, CAD-drawings can be displayed in the same colour on foreign computers (e.g. of other users or customers) without requiring a separately supplied material file.

**BOM export to Excel via template file (64Bit) (NL 5/2011)**

If you want to perform a BOM export to Excel via a template file in the 64Bit version of HiCAD or HELIOS, but this option is greyed out, you need to download and install the 64Bit version of the Microsoft Access Database Engine 2010 Redistributable components from the Microsoft homepage. The installation of these components needs to be performed with the option `/passive`, i.e. the call required for installation is `AccessDatabaseEngine_x64 /passive`.

---

**2-D**

**New data format for 2-D files (March 2017)**

Similar to the KRA files in 3-D, HiCAD now also offers figure archive files in 2-D with the file name extension .FGA. They contain the previous 2-D data (.FIG), the DB attributes (.FIG.DBA2) and the attribute container data (.FIG.ATC) and replace the previous 2-D files. Furthermore, the new FGA format allows a displaying of 2-D files in the HiCAD Viewer and also contains the 2-D HCM data.

HiCAD 2017 comes with the new 2-D figures archive with the file name extension .FGA. Please use only this new .FGA format for conversion of existing 2-D .FIG files! For this purpose, use the new Converter_FIG_To_FGA.exe tool in the HiCAD\exe directory. The Converter can also be installed from the HiCAD DVD.

When you update to HiCAD 2017, the 2-D parts that are supplied with HiCAD by default (e.g. drawing frames) will be converted from FIG to FGA in various folders in the installation directory. Before their conversion, the data will be saved in their original state in a folder or ZIP file, respectively, to the "Szenen" and "Catalogue" directory. Also, a LOG file recording the conversion will be saved to both directories.

When using an interface between HiCAD 2017 and HELIOS you will be prompted to adjust the database accordingly after a new installation or an update. Please note that the search for and management of 2-D parts will only possible after successful adjustment of the database and conversion of the existing FIG files.

For further details please read the PDF file New data format for 2-D files.

**DWG-Import - Kurven glätten (Juni 2016)**

In practice, it can happen that arcs and splines approximated by straight lines look a bit "unaesthetic" after the import of DWG files.
This can be remedied by the following procedure:

1. Open the file hcadacad.dat (HiCAD sys subdirectory) and change the setting for splines to 0. Save the file.

2. Import the DWG file: Drawing > New/Open > Open > DXF/DWG/V11

3. Export the file to DXF format (with the new settings in hcadacad.dat): Drawing > Save/Print > Save as > DXF/DWG

4. Open the DXF file: Drawing > New/Open > Open > DXF/DWG/V11

5. When you now apply the **Arc without tangent** function (2D Geometry > Draw > Arc) with the desired tolerance limit to the corresponding (or all) lines, they will be smoothed visibly. (Click here for a detailed description of the function.)
You determine a point on a contour here by entering the distance from the start or end point of the contour.

Please note:

When the input prompt *Select graphical element for contour start* appears, the position of the cursor relative to the selected line (to its right or left) will determine the direction. The direction will be selected in such a way that the cursor will be located on the left hand side of the edge with regard to the running direction. If you choose the c-edge with an incorrect orientation, resulting in a c-edge length smaller than the entered distance, an error message will be displayed. Click OK to correct the distance.

Example:

(1) Selected distance: 100; (2) Selected line element - Cursor left; (3) Point for contour end = right-click; (4) Distance point
If the cursor is placed to the right of the line during its selection (with the same value inputs), an error message will be displayed:

These point options are only available in 2-D.

2-D parts – Move multiple selection (January 2015)
As with 3-D parts, it is possible to transform (e.g. move) several 2-D parts in one step. Various options are available (e.g. free moving).

Possibility 1:
- In the ICN, select the parts that you want to move in one step by clicking them while holding down the left mouse button.
- Select 2-D Part > Transform > Move > ... > Move part, free (2-D).
- Specify the displacement vector.

Possibility 2:
- Select 2-D Geometry > Transform > Move GE, free (2-D).
- Choose either In rectangle or Within contour.
- Specify the rectangle or the contour around the parts to be moved.
- Specify the displacement vector.

2-D – View figures in ICN (January 2015)
As of HiCAD 1902.2, only those 2-D view figures that belong to the active sheet or model will be listed in the ICN.

2-D scale in ICN (November 2014)
For 2-D parts, the scale in the Properties tab of the ICN is represented as 1:n [1:m]. The scale shown in square brackets is the part scale, the other scale is the result from part scale and main scale of the drawing.

If the main scale is, for example, 1:2, and the part scale is 1:3, then 1:1.5 [1:3] will be displayed. If the main scale and the part scale are identical, e.g. 1:2, the part will (in relation to the main scale) be displayed without size change.

An example:
The displayed drawing was created with a scale of 1:2. Then, the two parts of equal size were drawn. In both cases, a scale of 1:1 [1:2] will be displayed.
If you now set the part scale of Part 2 to 1:3, this will cause Part 2 to be displayed smaller in relation to the main scale. A scale of 1:1.5 [1:3] will then be displayed. The scale for Part 1 will remain unchanged.

2-D Tabular Dimensioning · Sorting (NL 7/2013)

When changing the settings of a tabular dimensioning (right-click tabular dimensioning and select Edit tabular dimensioning > Settings), please note the following:

If the Lock sorting checkbox has been activated on the Sorting tab, the sorting defined in the upper area of the window will be disabled, and the table will be rearranged unsorted after closing of the window.

“Create revision cloud” function moved to „Construction Aids“ function group of 2-D Part tab (NL 6/2011)

In HiCAD Version 1601.1, the location of the Create revision cloud function has changed: To access the function, activate the 2-D Part tab and select Construction Aids > Others.

3-D

3-D - Create and process parts

Spirals – External references in processings (September 2017)

Spirals are automatically parameterised upon their creation, i.e. a corresponding HCM model will be generated (as of HiCAD 2017). Via this HCM model spirals can be changed subsequently. If the spiral is saved as a 3-D part (.KRA), it will be saved together with the HCM model. This means that once created, spirals can be reused and individually adjusted in any model drawings.

For spirals, too, the feature setting External references in processings will be assessed. Based on this setting the behaviour regarding external references will be adjusted.

An example:

The active drawing contains a cuboid. Now a spiral will be created which uses an edge or two
points (e.g. start point, end point or centre of a cuboid edge) as an axis. For the start point of the spiral another point on the cuboid will be chosen. This means that the spiral axis as well as the start point refer to the cuboid, i.e. have external references.

(1) and (2) start and end points of the spiral axis, (3) start point

The feature setting **External references in processings** determines how the spiral behaves, if the spiral itself or the cuboid are being moved. In order to activate this setting for the spiral, right-click into the spiral's (empty) feature log and select **External references in processings**... from the menu. Afterwards select the desired option. The ISD default setting is **Do not use**.

If you select the **Use** option and then move the cuboid, the references to the cuboid will be considered when changing the spiral with the **Change parameter** function in the HCM context menu or when updating the HCM model with the **3-D Standard > HCM > Tools** function.
For instance, if the number of windings is changed via the **Change parameter** function, the spiral axis will be located on the cuboid edge that was selected during spiral creation again, and the start point will be located on the mid-point of the cuboid edge.

However, if the **Do not use** option is selected, the references to the cuboid will not be considered when changing/updating the spiral.

**Select cylinder/cone axis as direction vector or rotation axis (December 2016)**

You can choose a lateral surface of a cylinder or cone to select the cylinder/cone axis as direction vector or rotation axis. The direction will be determined by the current cursor position.

(as of HiCAD 2016 SP2)

This concerns the following functions:

3-D-Standard > Process > Wall > Envelope
<table>
<thead>
<tr>
<th>3-D-Standard &gt; Process &gt; Clone processings...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sketch &gt; Transform &gt; Move...</td>
</tr>
<tr>
<td>Sketch &gt; Transform &gt; Rotate</td>
</tr>
<tr>
<td>Sketch &gt; Transform &gt; Mirror...</td>
</tr>
<tr>
<td>Sketch &gt; Clone &gt; Move...</td>
</tr>
<tr>
<td>-------------------------</td>
</tr>
<tr>
<td>Sketch &gt; Clone &gt; Rotate</td>
</tr>
<tr>
<td>Sketch &gt; Clone &gt; Mirror...</td>
</tr>
<tr>
<td>Sketch &gt; Draw &gt; Freehand &gt; Transition curve</td>
</tr>
</tbody>
</table>
Use the **Clone Part - Move, Parametric Along C-Edge** function to create clones of the active part or part list that run along a composite edge. If you have selected a closed polyline, you need to observe (depending on the current constellation) the start point of the c-edge. To detect this point, choose **Information, 3-D Further > Line > Polyline**.

(1) **Start point**, (2) **Direction**

**3-D detail views of sections / cut-outs (January 2015)**

When creating a detail view of a sectional view or of a cut-out, the current state of the sectional view or the cut-out will be copied into the detail view. If the section or the cut-out of the original view is changed afterwards, this will have no effect on the detail view. This means that the section or the cut-out needs to be changed separately if required.

**Add sweep with offset (November 2014)**

If you want to perform an addition in +Z-direction (**Add via Translation**), with the addition not beginning directly on the selected sketch, but with a certain distance from it, this can be achieved by specifying an additional negative value in -Z-direction.
Exchange 3-D parts (NL July 2014)

Dimensionings of the part to be replaced will be assigned to the new part (Drawing > Insert Part > Exchange 3-D part). The base points of all dimensions on the part to be replaced will be transferred to the new part and will be made associative by means of geometrical search. If this is not possible, the dialogue for the updating of dimension associativity will be displayed. As of HiCAD 1901 you can select the Redetect base point objects from geometry option. This option can be useful if, for example, the part to be replaced has dimensions the base points of which are located on other parts. The base points of such dimensions can get lost during the exchange without updating of the dimension.

3-D - Line parameters for axes and crosshairs (NL 2/2014)

The line parameters for axes and crosshairs (3-D Standard > Tools > Crossh.) can be changed via the feature log.

- Clicking the Line parameters entry opens the named dialogue window, enabling you to specify the values for colour, line type and layer. The entries will then be changed accordingly in the feature log.
If you set the value for Centre line to No, the axis will not be displayed as the centre line, but the current values set in the feature log will be used for its representation.

Performance increase by reduced opening of drawing files (NL 6/2013)

To enable a faster assembling of individual components in drawings, HiCAD offers the possibility of data reduction: If you activate the Open drawing, reduced option in the dialogue for the opening of drawing files, referenced 3-D parts/assemblies will be displayed as “reduced” elements, i.e. only the corresponding polygon model will be loaded, which reduces the amount of data. When working with large models, less memory will be required, which in turn leads to an increased performance.

The data reduction can either be applied immediately, i.e. when opening a drawing, or subsequently for individual parts or assemblies.

Further information on data reduction can be found in the Online Help, at 3-D > Referencing > Data Reduction.

Further tips on performance optimisation can be found in our Whitepaper HiCAD Performance Optimisation.

Form assembly (NL 5/2013)

Assemblies can also be created from existing 3-D parts.

1. Right-click the desired part in the ICN or in your drawing. Multiple part selection (CTRL+left-click) is also possible. Mark the desired parts and right-click your selection to open the context menu for 3-D parts.
2. Select the Form assembly function (below Edit structure in the context menu).
3. The Part attributes mask will be displayed. Enter the desired attributes. If required, select the assembly type from the Part type list box. You can choose between general assemblies, bolted assemblies (site) and welded assemblies (workshop).

The way in which the assembly will be formed depends on the part that you right-clicked.

If the function is applied to 3-D parts (solid primitives, beams + profiles...) all selected parts will be subordinated to a new assembly. The assembly main part will be the right-clicked part.

If the function is applied to dummy parts or 3-D sketches (with sketch geometry), the right-clicked part will be converted to an assembly and HiCAD proceeds as follows:

- All other selected parts will be subordinated to this new assembly
- The sketch geometry will be contained in this assembly
- Planar sketches will be handled like 3-D parts (i.e. they will be subordinated and not converted)

Using the part selection filter (NL 4/2013)

Irrespective of whether you identify 3-D parts in the drawing or in the ICN, you can restrict the part selection by the setting of filters. You can use this option for the selection of individual parts, for the definition of part lists, or the selection of parts in a rectangle.

Activate the part selection filter as follows:

1. Press and hold down the CTRL key.
2. Right-click a 3-D part in the ICN or in the drawing.
3. In the context menu, select Enable part selection filter.
4. The Part selection filter dialogue window will be displayed.
5. Use the options in the **Select part, when** area to specify the conditions for the selection of parts via a rectangle. **All points in box/rectangle:** If you have chosen this option, a part will only be considered as "selected" if all of its identification points are located within the rectangle. "Identification points" are the points listed in the upper area of the dialogue window. For example, the selection of a cuboid will only take place if all its corner points are located within the rectangle. **One point in box/rectangle:** If you choose this option, a part will already be considered as "selected" if only one of its identification points is located within the rectangle.

6. In the **Part type** area, you can specify the particular part types you want to be considered for the selection, e.g. only Steel Engineering parts, only standard parts etc. To exclude parts from the selection, deactivate the corresponding checkbox. Click **All** to activate all part types, click **None** to deactivate all part types. If you want the filter settings to be considered for the next selection, activate the **Use for next selection** option.

Please also see HiCAD Online Help, Part selection

**Behaviour of "named points" in connection with assembly insertion (NL 3/2013)**

As of Version 1702.3 the behaviour of so-called "named points" in connection with assembly insertion is as follows:

- The assembly contains a point with point number "!". No further named points exist in the structure of the assembly. When inserting the assembly, the cursor is attached to the named point. No specification of a fitting point on the assembly will be required.
- The assembly contains no point with point number "!". One or several named points exist in the structure of the assembly. When inserting the assembly you will be prompted to specify a fitting point on the assembly, and the position of this point in the drawing.
• The assembly contains a point with point number "1". Further named points exist in the structure of the assembly. When inserting the assembly, the cursor is attached to the point with point number "1". No specification of a fitting point on the assembly will be required.
• The assembly contains no named points. When inserting the assembly you will be prompted to specify a fitting point on the assembly, and the position of this point in the drawing.

C-edge sweep · Arbitrary cross-section (NL 13/2012)
When placing a free cross-section, the (first) guideline must always intersect with the cross-section plane; this applies in particular in cases where the guideline is exchanged via the feature log. If the new guideline does no longer intersect with the cross-section plane (e.g. because it has been shortened), the sweep body creation will not be possible.

Cloning of parts along composite edges (8/2012)
When you apply this function (available as of HiCAD 2012), the original part will not be moved. Therefore, the specification of the start width and the shortening at the c-edge start will only make sense if the original is not located at the start of a c-edge.

Example - Shortening of c-edge at start and end In the image below 5 clones of the original part have been created - 3 in negative, and 2 in positive direction. The shortening at the start is 25, the shortening at the end is 60. The clones have been placed with even distances, taking into account the c-edge length. The fitting point is the bottom left corner of the original.

Function Simulations (NL 7/2011)
The following function simulations are frequently requested by customers:

1. One front wheel and one rear wheel (i.e. different rotation axes) moving in the same direction.
2. Two counterrotating gearwheels (i.e. different rotation axes and movements in opposite directions).
3. Bevel gear drive (i.e. different rotation axes positioned at 90 degrees to each other)

This can be resolved as follows:

• In all three cases you select HCM > Simulation > Extended. Please make sure that the superordinate assembly of the two parts is active!
• First select the two parts, one after the other, in the Parts area of the dialogue window. Then define the different rotation axes in the Rotation tab on the right hand side of the dialogue window.
• By entering 3600 degrees in the Total angle field, you can also perform 10 rotations instead of 1 rotation. You can slow down the movement by changing the value in the Number of steps field accordingly.
• For Pt. 2. you need to select a negative rotation for one of the two parts, i.e. for example -3600 degrees instead of 3600 degrees.

Parametric constraints between the two parts will not be necessary here. You can as well define (instead or in addition) DIFFERENT translations.
3-D - Views

3-D Views – Sort and number sheet areas (September 2016)

The order of the Sheet areas in the Views windows in the ICN can be conveniently changed via Drag & Drop. You can move individual or several Sheet areas in one step.

Individual or all Sheet areas can be re-numbered consecutively. The first number can be freely selected. The following numbers will be numbered consecutively in the order of the displayed Sheet areas. Multiple selections are also possible.

Also new is the Sort, ascending function that allows you to sort the Sheet areas in ascending order by sheet numbers, e.g. after changing of sheet numbers or after changes of the sorting via Drag & Drop.

The sorting order of the Sheet areas will be saved together with the drawing. (as of HiCAD 2016)

see also Online Help

Stereoscopic Representation (April 2016)

In stereoscopic representation

(Views > Properties ), two central projections - one for the left eye and one for the right eye - are created. These stereoscopic images are identical but are slightly offset, i.e. they do not coincide. A suitable hardware in conjunction with 3-D glasses merges these two stereoscopic images into one image conveying a three-dimensional impression.

Please note:
» The stereoscopic representation is only carried out for shaded views.
» The stereoscopic representation is carried out during dynamic rotation and while the settings window is open.

Views: Shortening parameters (Dec. 2015)

As of HiCAD 2015 SP2 the

Shortening parameters function will be available at Views > Edit > Shorten > ... . The function replaces the Break line type function that was previously available in the Drawing properties menu and offers much more setting options. For example, you can specify for zigzag lines that no zigzags will coincide with the mod point of the break line.

Break line types in shortened views (August 2015)

Use the Break line type function in the Properties function group of the Drawing tab to change the appearance of break lines for shortened views. Possible are straight lines and zigzag lines. The default setting is "Zigzag lines". You can change this setting in the Configuration Editor, at Drawing > Views.

Show/Hide Parts and Views

Especially in large drawings in can be useful to hide currently unused parts and views for a more comfortable working. HiCAD offers various options for this.

show_hide_parts.mp4

Show only active view

1. Activate a view in the drawing.
2. Right-click the Show only active part icon in the transparent toolbar and select the Show only active view function in the context menu.
3. To display all views, right-click the Show all parts icon in the transparent toolbar and select the Show all views function in the context menu.
Working with central projections (Mar 2015)

When working in the central projection, not all point options may be available, e.g. the point option (Z) Centre.
Therefore, a creation and processing of 3-D models in the central projection is not recommended.

Base points of 3-D dimensions in shortened views (NL August 2014)

3-D dimensions the base points of which are located in an omitted area of a shortened view will not be displayed (a suppressible message will be displayed when such a dimension is found).
Such dimensions cannot be represented in any way.

Detail/sectional view – Font (NL3/2014)

The representation of Detail view identifiers in the original view can be changed in the ANSGEN.DAT file in the HiCAD SYS-directory. In lines 73/74 of the file you can find the parameter

```
Detailansichtskennzeichnung (Schicht, Staerke, Farbe, Art) [Detail view identifiers (Layer, Weight, Colour, Type)]
```

```
1 1 4 1
```

For example, if you change the entry 1 1 4 1 to 1 1 3 1, the frame of the detail view identifier will no longer be red (default), but blue.

The font of the detail view identifier as well as the font of the letters at the section paths of sectional views (not the caption!) can also be specified in the ANSGEN.DAT file (lines 91-96).

```
1 = normgerecht nach DIN ISO 128 [1 = According to DIN ISO 128]
```

-1
Text colour for view identifiers (-1 = default) - Schriftfarbe für Ansichtskennzeichnungen (-1 = Standard)

-1
Font for view identifiers (-1 = default) - Schrifttype für Ansichtskennzeichnungen (-1 = Standard)

-1

If the default setting -1 is set here, the currently set 2-D font will be used.

Behaviour of new parts in list views (NL 4/2013)

In the ANSGEN.DAT system file of the HiCAD SYS directory you can change the behaviour of new parts in list views, namely, via the setting:
Include new parts in list views (0:no, 1:yes) - Sollen neue Körper in Listenansichten aufgenommen werden (0:nein, 1:ja) 0

Select 1 if you want new parts to be shown in all views. Select 0 if you want new parts to be hidden in all list views, except for the active one. This is the default setting.

Exploded view
The Exploded view function will not be applied to the current view, but to the complete drawing (i.e. to all views, including the Model area!).

"Show scale" option in dialogue window for sectional views (NL 12/2012)
In the dialogue window for sectional views you can find the Show scale checkbox below the Caption for sectional views checkbox. Please note that the scale is only shown in a sectional view caption if the sectional view has a different scale than the original view. If the sectional view has the same scale, the checkbox can be activated (e.g. for later scale changes), the scale will however not be shown in the caption.

Calling View/Zoom functions via the keyboard (NL 8/2011)
If the cursor is placed in the drawing area, the functions listed below can also be called via the keyboard:

<table>
<thead>
<tr>
<th>View all</th>
<th>Home</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangular zoom window</td>
<td>End</td>
</tr>
<tr>
<td>Rotate view (with the mouse)</td>
<td>Ins</td>
</tr>
<tr>
<td>Redraw</td>
<td>Del</td>
</tr>
<tr>
<td>Zoom step-by-step</td>
<td>PgUp/PgDn</td>
</tr>
<tr>
<td>Move detail</td>
<td>Cursor keys</td>
</tr>
</tbody>
</table>

Views – Define required position (NL 2/2011)
You can define a so-called “required position” for 3-D views. It enables a returning to the original position if an object has been transformed several times.

To define a required position, proceed as follows:

- Activate the desired view.
- Transform the view into the required position through rotations, translations etc.
- Select Views > Transform > Set as required position.

The Transform to required position function enables you to restore the originally defined required position at any time, e.g. after several transformations of a view.

Please note:
The required position also includes the view scale, i.e. the current view scale is saved together with the required position and will also be restored to the originally defined scale when you use this function!

Shortened views (NL 2/2010)
Please note that shortened views are not possible for shaded OpenGL representations. If you use HiCAD 2010 (SP1) or a newer version, an appropriate message will be issued. You can then decide how to proceed further. For instance, you can change the type of representation and immediately continue the function. In older HiCAD versions you needed to change the type of representation first, and then call the shortening function again.
3-D - Representation

Assign textures (NL October 2014)

To assign textures to 3-D parts, open the Visual effects docking window, and double-click the texture you want to apply. The chosen texture will then be shown as a symbol next to the cursor.

As long as this representation is active, you can select the parts to which you want to apply this texture, one after the other, by means of a mouse click.

From HiCAD 2014 (Version 1902) onwards you will have the option Copy texture settings from part function to apply textures of parts to other parts.

Optimal representation of your models with high-resolution graphics (NL 2/2012)

Ideally, save the images as individual graphics files. The best results will be obtained with the following settings:

- Press CTRL+C
- In the “Copy to clipboard” window, select “Bitmap”
- Pixel size “2500*2500”, click “OK”
- Draw a rectangle around the desired detail
- Select “White” as background colour
- Paste to image processing program (e.g. MS Paint) and save as tif or jpg file

A detailed description can be found in our Online Help: Create pixel graphic

Optimal representation of “round” geometries in shaded mode (NL 1/2012)

The “accuracy” of the representation of round geometries in shaded mode can be influenced in three ways:

- Temporarily, i.e. until the next HiCAD start: Select Extras > Temporary settings > Approximation of curved surfaces (until HiCAD 2011).
- Permanently for one drawing (as of HiCAD 2012: On the Drawing tab, select Properties > Attr. > Surface approximation). In this case the setting will apply only to the current drawing, and the default setting will be used for other drawings.
- Permanently as a basic setting in the system file krpgen.dat, in the entry Approximation dimension for polyhedral approximation for 1/4 circle. We recommend changing the basic settings only if temporary settings or drawing-specific settings would otherwise require frequent changes. Please note that an increased “accuracy” will also lead to an increased data volume.

Resolution of shaded graphics for printouts (NL 1/2012)

The resolution of shaded graphics for printouts can be set in the system file “plopar.drf”, in the entry “Max. Bitmap-Auflösung pro schatt. Ansicht” (Max. Bitmap resolution per shaded view).

Hidden Line Collision Check (NL 1/2010)

When you activate the Hidden Line calculation, HiCAD always checks the drawing for possible overlaps and collisions and corrects these automatically. Alternatively you can also select a more accurate Hidden Line collision check. To do this, you need to adjust the entry in the Windows registry accordingly.

As from Version 1401.2H: HKEY_CURRENT_USERSoftwareISD Software und SystemeHiCAD neXt 14HiddenLineCollisionEffort

As from Version 1501.0 (2010 SP1): HKEY_CURRENT_USERSoftwareISD Software und SystemeHiCAD 2010HiddenLineCollisionEffort
After installation (or the update to Version 1401.2H, resp. 1501.0) the value is set to 1 = “Quick Hidden Line calculation”. If you want to perform a more precise collision check, set the value to 2. You do not need to re-start HiCAD for this change to take effect.

Please note:

- We recommend that you apply this change to all of your HiCAD workstations (and for all users) to avoid differing representations within your company. Please also note that differing representations may occur if you pass your drawings to third parties using different registry settings.
- Especially for large and complex drawings a precise Hidden Line calculation may take a little longer than usual.

3-D - Dimensions/Annotations

Surface Symbols - The SURFSYM.INI file (October 2017)

In connection with the surface characters the system file SURFSYM.INI in the HiCAD SYS directory plays an important role.

This file has the following purposes

1. In this file you can determine the contents of the selection boxes of the Surface specification dialogue window. This is done in the lines 1 to 7, i.e. from A1_TEXT to E_TEXT.

   For instance, if you expand the line B2_TEXT by “Rolled”, this new entry can then be chosen from the selection box.

   \[\text{[B2\_TEXT]} = \text{%ts(SURFSYM\_GRIND\_ED)}; \text{%ts(SURFSYM\_RAW)}; \text{%ts(SURFSYM\_MILLED)}; \text{%ts(SURFSYM\_CLEANED)}; \text{Rolled}\]

   HiCAD uses the keyword %ts to gain access to the internal text service. This will not be required for your own additions, though.

2. Here, the default settings of surface characters for new model drawings are defined.

   The default settings can be changed at any time via 3-D Dimensioning + Text >
Surface/Edge > Surf...> Settings

Extensive information can be found in the Online Help.

Define Surface Information – Save / Load favourites (March 2016)

You can save the current settings for surface specifications as Favourites and re-use them at any time.

Please note
Specifications regarding concerning the representation (font and colour) will not be saved in the Favourites.

Base points of 3-D dimensions in shortened views (NL August 2014)

3-D dimensions the base points of which are located in an omitted area of a shortened view will not be displayed (a suppressible message will be displayed when such a dimension is found). Such dimensions cannot be represented in any way.

Settings for fits tables (NL 4/2014)

The settings for the Fits table function (3-D Dimensioning+Text > Tools > Extras) can be preset in the Configuration Editor, at Drawing > Annotation > Fits table. In this way, you can, for example, change headings.

Visualisation of parametric dimensions (NL 1/2014)

Use the Visualisation- Parametric dimensions function (3-D Standard > Tools > Attr...) to specify when parametric dimensions are to be visible in your drawing.

The default setting in the dialogue window of the function can be defined in Lines 36-38 of the PARAMASS.DAT file in the HiCAD SYS-directory.

Parameterbemaßung einblenden in aktiver Ansicht fuer aktives Teil/ aktiven Featureschritt des aktiven Teils/ nicht einblenden (1/2/0)

(Show parametric dimensions in active view for)
When changing a 3-D bore table (right-click bore table and select Edit table > Settings), please note the following:

If the **Lock sorting** checkbox has been activated on the **Sorting** tab, the sorting defined in the upper area of the window will be disabled, and the table will be rearranged unsorted after closing of the window.

To save the parameters of the 3-D dimensionings permanently, specify the desired settings in the dialogue window of the **Set parameters for new general dimensions** function (3-D Dimensioning+Text > Tools...) first. Then, select the **Save parameters** function in the pull-down menu of the same function and save the settings as **DIMENSIONING_SETTINGS.XML**. The pull-down menu also contains functions enabling you to specify the settings for parametric and HCM dimensions, which can be saved in the same way as general dimensions (all settings will be saved to the aforementioned file).

In all dimensioning functions, you can activate the **Element type selection** dialogue window with a right-click. Here you specify which elements (points, edges, or surfaces) you want to allow for selection. The dialogue window can be activated whenever HiCAD prompts you to identify the element to be dimensioned. This option can be useful in many situations: When dimensioning circles, arcs or ellipses, for example, it makes sense to immediately identify the required edge or surface instead of selecting a point option, such as Q, S2 or R. Right-click to open the **Element type selection** dialogue window and activate the required element types.

---

### 3-D - Sketches

**New Spiral function (June 2017)**

The dialogue of the Spirals function has been redesigned in HiCAD 2017.
Besides a generally enhanced user-friendliness, the new dialogue offers the following advantages:

- The spiral is immediately visualized dynamically.
- Curve creation is more accurate now.
- Besides cylindrical spirals you can now also create conical spirals.
- Start and end of the spiral can be modified individually.

**Example 1:**
The image below shows spirals that have been used as guidelines for the placing of a circular cross-section (C-edge sweep function).
Example 2:
In the next image a spiral has been "wrapped" around a cylinder, and has then been used as a
 guideline for the placing of a circular cross-section. After this, the resulting body has been
 subtracted from the cylinder.

Extensive information on this function can be found in the Online Help.

Sketches - Spline Properties (July 2016)
Splines in HiCAD can have three different properties:

**Fixed**
The spline is in "read-only" state, i.e. its form and size cannot be changed.

**Flexible**
Any point of the spline can be changed freely. This is the default setting.

**Scalable**
The form of the spline remains fixed, but the size of the spline can be changed, i.e. it can be
 enlarged or downsized.

In previous versions, the spine properties could only be changed via Sketch > HCM > Fix > ...
 > Positional constraints > Spline property. Since HiCAD 2016 SP1, this can also be done
 via the HCM window of the ICN. Here you distinguish between two cases:

1. If a HCM constraint has been assigned to the spline, you can change the spline
 property by right-clicking the Spline... item and selecting the desired property in the
 context menu. The currently active property will not be shown in the context menu, i.e.
 if a spline has the property Scalable, only the properties Fixed and Flexible will be
 offered for selection.
2. If no HCM dimension has been assigned to the spline, right-click on the HCM window and choose **Sort according to geometry** (if required, select Sketch > HCM > Tools first). Now you can again click on the spline ... item to change the spline property.

**Using sketch elements as auxiliary geometries (NL 8/2011)**

Sketch elements can be defined as auxiliary geometries. These will be ignored when you create parts based on sketches, e.g. extruded/revolved parts, beams, profiles or plates derived from sketches etc. Auxiliary geometries can be used as construction aids, e.g. during the assigning of HCM-constraints, as rotation or mirroring axes etc.

**Modify grid in sketching function (NL 3/2011)**

Sketch technology has various grid modes that can be selected from the context menu (click RMB). You can use the +/- keys to affect the precision of the distance display

- **Minus ( - ) key**: Refine grid,
- **Plus ( + ) key**: Coarsen grid,
- **Space bar**: Direct value entry.

**3-D - Miscellaneous**

**BOM-relevance and item numbers for referenced parts (NL 1/2014)**
If you assign the attribute "BOM-relevant" to one of several referenced identical parts subsequently, this attribute will not be automatically transferred to the other parts. The same behaviour is shown, for example, by item numbers. They will, however, be transferred to the other identical parts if you perform a manual updating with the Update, Identical parts, active part function in the context menu for referenced parts (after confirming the security prompt).

If you change the entry

```
"#SR" "INTEGER" "NIE" # BOM-relevance
```


 to

```
"#SR" "INTEGER" "ALG3DPAR" # BOM-relevance
```

in the REF3D_ATTR_AKR.DAT in the HiCAD SYS directory, in the BOM-relevance, too, will be transferred when performing a manual updating.

Geometrically identical part search for auto-itemization (NL 8/2012)

For automatic itemization, you can activate the geometrically identical part search for "general" 3-D parts (i.e. non-Steel Engineering parts) via the line 

```
Bei der geometrischen Gleichteilerkennung alle Teile berücksichtigen (Consider all parts for identical part search)
```

in the system file "stb_parameter.dat". If this option is not active, general parts will always obtain different item numbers, even if parts are geometrically identical. Please note however that activating this option will slow down the identical part search for auto-itemisation.

Derive exploded view drawing from assembly drawing (NL 6/2011)

Exploded view drawings can be derived from assembly drawings. When performing such derivations, customers usually require the following:

1. If parts are changed in an assembly drawing, they should automatically be adjusted in the corresponding exploded view drawing (otherwise you would have to do the same work twice and have the risk that one of the two drawings is not up to date). This simultaneous changing can only be achieved through referencing.
2. Despite the referencing mentioned in 1., the assembly drawing must, of course, not be represented in exploded view (freezing views is not a good solution, as this would prevent further part modification).

This can be achieved by right-clicking the referenced part and selecting Referencing > Setting Update, Position > Retain position of drawing. This function must be selected both for the assembly drawing (where the parts need to remain in an assembled position) and the exploded view drawing (where the parts need to remain in exploded view representation).

Unilaterally associative copies of referenced parts (NL 1/2009)

Use the Part from referenced part function to create unilaterally associative copies of referenced parts. In contrast to other fitting functions for referenced parts, the copy will not be saved as a referenced copy in the part structure of the current drawing, but only in the feature protocol. Here, a feature called Referenced base part will be created. All subsequent changes to the copy, e.g. boring, mirroring or scaling, will be included as new features in the protocol, and do not influence the corresponding original. If you want to apply the changes to the original to the copy as well, right-click the entry Referenced base part in the feature protocol of the copy and select Re-calculate. If the referenced original part changes, the associated referenced base part is usually updated first during feature protocol re-calculation and only afterwards are the other actions in the feature protocol applied to the updated part. On the other hand, changes made to a referenced base part in the feature log do not effect the corresponding original part.

Feature/HCM

Feature / 3-D - Clone processings (November 2016)

The Clone processings function allows you to apply one or several processing steps in the feature log multiple times, i.e. the processing will be "cloned", so to speak. You can call the function either via 3-D Standard > Process > Clone processings, or by right-clicking a feature log entry and selecting "Clone feature".

When you call the function, the following dialogue window will be displayed:

(1) In this area, the features of the active part are listed. Use the checkboxes preceding the features to select the features you want to clone. If a feature is greyed out, it cannot be cloned.
If a feature is highlighted in blue, you need to perform a recalculation before you can clone the feature.

The following processing steps can be cloned:

- Add, via translation / rotation
- Subtract, via translation / rotation
- Fillet and Chamfer
- Boolean operations: Add, Subtract, Difference
- Some, but not all Standard Processings
- Rotate surface
- Isolated point
- Deform: Bend, Twist, Taper, Stretch
- Appearance (e.g. colour of surface)
- Move edges
- Crosshairs
- Wrap
- Fitting CS
(2) Use these buttons to add linear, rotatory, polyline or translatory + rotatory patterns. You can also add several patterns, which will then be applied one after the other.

(3) In this area the added patterns are displayed and can then be modified or deleted.

(4) In this area you can define Omissions.

(5) Click the Preview button to switch the preview of the cloned features on or off. Use the Clone, one-sided checkbox to activate or deactivate the option to apply clonings also in the opposite displacement or rotation direction.
Example:

The anti-slip nubs on this stool were cloned on the basis of the nub in the bottom left area - first, linear to the top, and then rotatory to the right. The following omissions were defined:

- 1. 1 for the missing nub at the bottom left area (1st cloning of the linear pattern, 1st cloning of the rotatory pattern),
- 6. 0 for the missing nub in the top left corner (6th cloning of linear pattern. 0th cloning of rotatory pattern),
- likewise: 6, 4 and 6, 8 for the further nubs in the upper row and 0, 8 for the nub in the bottom left corner.

Extensive information on this function can be found in the Online Help.

**Copy Feature / Insert Feature (August 2015)**

The **Copy feature** function (in the Feature Technology context menu) enables you to copy a processing feature to the clipboard and then paste the copy at another position in the feature log using the **Insert feature** function.

The feature will be inserted after the entry **Insertion position**. This prevents an automatic recalculation of the log after insertion of the new feature. This allows you to apply changes (e.g. of the processing plane or the position) before the recalculation takes place.

Multiple selections for the copying of features are also possible, e.g. to execute an action consisting of several processing steps several times.

**Error/error list in feature log (NL3/2014)**

Defective features are marked with an exclamation mark in the feature log. If you expand these features, you will find a more precise description of the error under Error list.

If you right-click on an error or an Error list, a context menu with the **Suppress** function opens. Use this function to suppress the display of the errors or the entire error list. The errors or the error list will then be greyed out and will no longer be written to the corresponding feature (as a result, the symbol for the part in the feature log will be changed accordingly). To display the errors again, right-click the error or error list again and select **Do not suppress**.
Left Feature log with displayed errors; Right: Feature log with suppressed errors

Use the **Copy text** function of the context menu to copy the text of an error in the feature log to the Windows clipboard.

**Derive feature variant from parameterised part (NL 6/2011)**

Feature variants can be derived from parameterised parts. In the process, you can either select suggested data records or freely enter specific values for width, length etc. For so-called "standard variants" (as opposed to "type variants") the user can select from suggested values only. Standard variants can be created if you save the variant to a catalogue. For this you need to perform the following steps:

1. Parameterise the part.
2. Right-click the feature log and select **Create feature variant**.
3. Right-click part > **Reference part, Save, Detail drawing > Save as part, with catalogue entry etc.** If required, you can previously create corresponding tables or even catalogues in the Catalogue Editor (CATEDITOR.EXE).
4. Move all files of the feature variant from the HiCAD drawings directory "Szenen" to the directory in which the .KRA file is located.
5. In the Catalogue Editor, exchange the extension .KRA with .FEV in the table, then save the table (please move cursor out of the table in the process!).

You can now load the feature variant: Activate the **Drawing** tab and select **Insert Part > Insert main part, via Standard Part catalogue**.

**As of HiCAD 2013, the above steps can be performed much easier:**

1. Parameterise part
2. Right-click and select **Reference part, Save, Detail drawing > Save as variant with catalogue entry**

The following steps (in the catalogue Editor) are only required if you want to convert a type variant to a standard variant. Values can then no longer be entered freely, but only suggested values can be used.

1. Create new rows by Copy & Paste (if you require 4 subtypes you need to create 4 rows).
2. Select **Sort values** to determine the sort values. All rows must have different sort values. For example, if BZ is the sort value you need to ensure that BZ has a different value in every row.
3. Right-click the column header and select **New column**. The Designation is the name of the variable that was used during parameterisation - Data type=Integer. If there are several variables, this step must be performed for each variable. Enter reasonable values into each row of the column.
4. Select **ID values** to add the variables names.
5. In all rows, select 4 for Type (4 stands for standard variant).
6. Move the cursor out of the rows and save the table.

If you now call the feature variant by activating the Drawing tab and selecting **Insert Part > Insert main part, via Standard Part catalogue, HiCAD will offer the defined standard sizes only.**
Purchased parts and Factory standard parts (July 2017)

On the 3-D-Standard tab at Standard Parts > BoltScrew >... > Others you will find the Purchased/Factory standard parts function. You can use this function to insert purchased parts or factory standard parts in you drawing from the Factory standards > Purchased/Factory standards catalogue, e.g. end caps or glass holders. If you are also working with HELIOS, these parts will always retain their article master, irrespective of the project to which they belong. Basically, this means that these parts behave like standard parts. (as of HiCAD 2017 / This function currently supports only single parts.)

These parts are of particular importance when working with the Management + BIM module, as it must be ensured in this situation that the parts/assemblies will retain the manually created/assigned article master(s) when being inserted into an existing project. Also, the sub-parts of assemblies must not be BOM-relevant.

If you want to save your own standard parts to the Purchased/Factory standards catalogue, please note the following:

The parts saved to this catalogue must have three isolated and unambiguously named points. These points determine the position and direction of the parts during their insertion. The point designations to be used are as follows:

1. Fitting direction
2. X-direction
3. Y-direction

Example: End cap for pipe with rectangular cross-section

Use the HiCAD function Reference part, Save, Detail drawing to save the parts.

Insert spring connector (August 2016)

In HiCAD 2016 SP1 some minor problems occurred with the correct positioning of spring connectors in cylinder holes. These problems have been solved in HiCAD 2016 SP1, Patch 1.

In this context, the dialogue has been modified. You now proceed as follows:

1. Select the outer cylinder of the shaft.
2. Specify the insertion point or identify the edge of a bore.

   Insertion point

   a. If you specify a point that is not located on the cylinder axis, the point will determine the insertion direction. The direction results from the specified point and the
perpendicular from this point to the cylinder axis.

b. If you specify a point that is located on the cylinder axis, the point will determine the insertion height with regard to the shaft. In this case the direction cannot be influenced.

c. If you select the Point option (M) “Mid-point of line/edge” for an edge of the bore, the spring connector will be placed in the bore. The insertion direction is the axis of the bore cylinder. Otherwise, the placing will be as described in a) or b).

Edge of bore

If you select an edge at the transition of the shaft facet to the bore, the spring connector will be placed in the bore.

3. If you want the spring connector to be rotated 180 degrees, answer the query with “Yes”.

Save weld symbol settings as Favourites (August 2016)

When inserting weld symbols, you can save the current settings as Favourites. Please note that only the welding-relevant data will be saved here. Parameters with regard to the representation will not be saved to the Favourites.

Catalogue Editor – Delete tables (Mar 2015)

Only tables in factory standard catalogues can be deleted.

Copy a norm processing

Did you know you can copy a standard processing from 1 part to an other part? Just activate the new part where you want to copy the norm processing on to. Put a workplane on the face you want to copy the norm processing to. In the context menu of Standard processings select the function Copy standard processing. Select the standard processing from an other part and apply it to the active part.
Thread in HiCAD simple and exact: showing washout of thread.
It's possible to view the washout of thread. This can be done to change from simple to exact.

By simply giving a RMB on the thread part (cylindrical part) and selecting the "Representation" option.

Activate/deactivate catalogues (11/2012)
If Catalogues are not offered for selection when you want to insert Standard Parts, Standard Processings etc., these Catalogues have possibly not been activated in the Catalogue Editor. Start the Catalogue Editor and use the CATALOGUE MAKER to activate the desired Catalogues and enable their use in HiCAD. Conversely, you can also use the CATALOGUE MAKER to restrict the range of selectable Catalogues in HiCAD.

Assigning of Cadenas attributes to HiCAD attributes (NL 7/2012)
When inserting parts from the Cadenas PartSolutions catalogues in HiCAD, the Cadenas attributes "Part No." and the Designation will be automatically assigned to the HiCAD part attributes $BB (Article number) and $01 (Designation 1). This assignment can be changed via the file STD.XML in the HiCAD directory SYS\CADENAS.

**Example: Attribute assignment**

```xml
<?xml version="1.0"?> -<AttribMap> <Entry H="$01" C="NB"/> <Entry H="" C="NN"/> <Entry H="" C="LINA"/> <Entry H="$BB" C="ARTNR"/> </AttribMap>
```

In this example the Cadenas attribute NB has been assigned to the HiCAD Attribute $01 (Designation 1), and the Cadenas attribute ARTNR has been assigned to the HiCAD attribute $BB (Article number).

**Sheet Metal Processing**

- Manual moving of auxiliary texts (October 2017)
  
  If you move the cursor over a text in the 3-D development, the text will be highlighted in magenta. If you now press and hold down the left mouse button you can move the text. (as of HiCAD 2017 SP2)

  When you update the development the text will be moved back to its original position.

- Sheet Metal development – “Outside with line” (September 2017)
  
  The Create sheet development dialogue window now offers the new positioning option Outside, with line. If you choose Positioning: Inside or …Outside, the dimensions and the article number and, in some cases, the item number will be displayed by default. The text is generated from the part attributes of the Sheet Metal main part. If you choose Outside, with line, the annotation will be placed as a tag with a leader line.

- Apply sheet development immediately (July 2017)
  
  To allow a fast realisation of sheet developments, the **Apply immediately** option has been added to the **Sheet development** dialogue window. If you have activated the checkbox, the development will be created in the drawing directly after selection of the fitting point. Clicking the **Apply** button will no longer be necessary.

- Sheet development - Text with leader line (April 2017)
  
  The **Auxiliary text – Positioning** setting in the **Create sheet development** dialogue now offers the additional **Text with leader line** option.
If you choose **Inside** or **Outside**, the dimensions and the article number and, in some cases, the item number, will be displayed by default. The text will be composed of the part attributes of the Sheet Metal main part. If you choose **Text with leader line**, the text will be applied as a tag with a leader line.

---

3-D developments (March 2017)

The new functionality for the creation of 3-D developments (as of HiCAD 2017) offers many advantages, e.g. the automatic drawing creation with shortening or the sheet development in a separate view. A manual reworking of the 3-D development is no longer possible. The functions **Acute corner** and **Simplify** have not been made available for 3-D developments in Version 2017 yet.

**Delete 2-D <-> 3-D** have not been made available for 3-D developments in Version 2017 yet.

Extensive information on this function can be found in the [Online Help](#).
We are currently working on the incorporation of these functions into the new, 3-D based development creation functionality.

BOM-relevance for new sheets (February 2017)

The part attribute BOM-relevant can be set for all new Sheet Metal parts in the SYS/ABWPAR.DAT file.

# Sheets BOM-relevant (yes=1, no=0)

1

This setting will now also be evaluated by the functions Sheet from solid and Connecting sheet.

Sheet from solid (February 2017)

The Sheet from solid function does generally not take over any standard processings, i.e. no threads, countersunk bores etc.

Sheet Metal – Bend angle-dependent parameters in blanks (November 2016)

You have now the option to individually specify bend lined in blanks with the settings of the file ABWCOL_BEND_ANGLE.DAT. Whether this file will be evaluated depends on the corresponding setting in the file ABWCOL.DAT. If you want the file to be evaluated, set the following parameter in the file ABWCOL.DAT to 1:

Biegelinienfarbe soll in Abhängigkeit vom Biegewinkel gesetzt werden; Datei "sys/abwcol_bend_angle.dat" (1: Eigenschaften aus Datei lesen; 0: nicht aus Datei)

1

and re-start HiCAD.

(1) Bend angle 0°- 95°, Line code (Layer, Colour, Weight, Type) 2411
(2) Bend angle 95°- 360°, Line code (Layer, Colour, Weight, Type) 2311
(3) Bend angle -360°- -95°, Line code (Layer, Colour, Weight, Type) 2013
(4) Bend angle -95°- 0°, Line code (Layer, Colour, Weight, Type) 2117

Sheet Metal – Several blanks in one drawing (August 2016)

As of HiCAD 2016 SP1 it is possible to derive several blanks with different setting options from one Sheet Metal part. The parameter settings are saved directly on the blank. In this way it is possible to save the blanks which are intended for export as DXF files, e.g. for LVD and Bystronic, with their different parameters in the same drawing. The different parameters will be considered when updating the blanks after modifications of the Sheet Metal part.
The Attach flange function offers various procedures for the attaching of flanges. To create a flange at an angle of 180 degrees, use the following options:

Reference:
Possible Fitting mode:

<table>
<thead>
<tr>
<th>Diagram</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="77x563" alt="Diagram" /></td>
<td>Without shortening</td>
</tr>
<tr>
<td><img src="77x516" alt="Diagram" /></td>
<td>Shorten, outer tangent</td>
</tr>
<tr>
<td><img src="77x465" alt="Diagram" /></td>
<td>Shorten, inner tangent</td>
</tr>
<tr>
<td><img src="77x415" alt="Diagram" /></td>
<td>To plane, outer</td>
</tr>
<tr>
<td><img src="77x372" alt="Diagram" /></td>
<td>To plane, inner</td>
</tr>
</tbody>
</table>

Example:
BOM-relevance for new sheets (March 2016)
The part attribute BOM-relevant can be set for all new sheets in the SYS/ABWPAR.DAT file.
# Sheets BOM-relevant (yes=1 , no=0)
1
From HiCAD 2016 this setting will now also be evaluated by the functions Sheet from solid and Connecting sheet functions.

Preset colour for moulding tools in sheet developments (October 2015)
The presetting of the line colour for the 2-D sheet development of moulding tools can be found in the ABWCOL.DAT file.

Line 31/32:
# Farbe 12: Umformkanten abcform (#Colour 12: Forming edges abcform)
32511.

Example

After a change of the presetting, HiCAD must be restarted for the changes to take effect.

Collinear sheet edges (February 2015)
HiCAD 2015 detects collinear sheet edges automatically, an activation by the user is no longer necessary. The previous functions Edges ON and Edges OFF at Sheet Metal > Sheet development > Param. > ... are no longer available. The hiding of collinear sheet edges now only takes place via the individual views (e.g. right-click view frame > Properties > Hide/show edges in view)).

In drawings from older HiCAD versions the automatic determination of collinear sheet edges will take effect after recalculation of views, e.g. after changes to any part in the drawing.

Sheet Development (NL 1/2013)
In the functions
- Sheet Metal > Sheet Development > Develop Sheet > Part (approximative)
Sheet Metal > Sheet Development > Develop Sheet > Part + Sub-parts (approximative)

the sheet thickness will be queried in case of a possible length change, which makes sense for cylindrical surfaces. For all other surface types the query can be skipped with a right-click (RMB = No length change).

Sheet metal and font style for lettering

When using HiCAD fonts with lettering in sheetmetal it seems only italic is possible. But other kind of styles are also usable!

**Where can this be changed?**

Font style for lettering can be changed in the HiCAD\sys\abwpar.dat

Please note: schrif.dat

Result of changes in the Abwpar.dat:

Font style for letterings (SCHRIF.DAT) 1 or Font style for letterings (SCHRIF.DAT) 3

---

**Steel Engineering**

**NCX export of connected multi-part beams (June 2017)**

It is now possible to treat itemized, non-connected multi-part beams as one part for NCX exports when generating the NCW files (as of HiCAD 2017).
When generating DSTV data the following numbers:

- Order number,
- Drawing number,
- Part number,
- Item number and
- Lettering

can be configured via the templates files (FTD) that have been defined for this purpose. Previously, the selection took place via the Configuration Editor. From HiCAD 2016 SP2 onwards, the selection is possible directly in the dialogue window of the DSTV-NC interface.

The DSTV templates will only be considered if you have chosen the From templates file option for letterings, drawing number, part number, item number and order number in the DSTV-NC interface dialogue number.

To adjust the template files, use the new Steel Engineering function Templates, Attribute assignment.
When beams are trimmed, the value assigned to the part attribute Length will be the total length of the trimmed beam. If two trimmings are applied to a beam, the calculated length will be the smaller of the two individual total lengths after applying the trimming. The beam length and the trimmed length will then be identical.

(1) Line for 1st trimming, (2) Line for 2nd trimming

Exceptions are cases where one of the trimmings is performed at a 90° angle. In such cases, the length resulting from the 90° trimming will not be considered for the calculation of the minimum (the reason for this are processing steps with a saw). Use the part attribute Trimmed length (§24) for a correct calculation of the trimmed length. This attribute can, for instance, be used for annotations, in part attribute masks or in BOMs. (as of HiCAD 2016)

Production Drawing - Usage-dependent drawing frames (June 2016)

Function: Drawing > Itemisation/Detailing > Derive

You can also specify usage-dependent drawing frames for detail drawings that are exported to an external drawing file. In the Configuration Editor beneath Automatic drawing derivation > Production drawing > Usage-dependent you can define, via the corresponding Drawing frames entry, the drawing frame for this usage.

To be able to use the desired drawing frame you need to change both parameters accordingly., e.g. as follows:
For the parameter **Usage-specific drawing frame** you need to enter the name specified beneath Drawing frames in the structure tree, and not the name of the figure file B!

**Important:**
- Usage-specific drawing frames can only be used for detail drawings. In such cases, the specified, usage-dependent settings of the uppermost BOM-relevant part will be read out. For workshop drawings (several parts in one drawing), the general setting for drawing frames specified at **Automatic drawing derivation > Production drawing > Drawing frames** will be read out.
- If you want to use usage-dependent drawing frames, one of the following options must be chosen as the Drawing target for the derivation:
  - To existing drawing,
  - To external drawing or
  - Detail drawings to external drawing
- Beneath **Sheet selection** you must (!) select **New sheet for each view group**

Click [here](#) for a detailed description of the function.
You use this **Structural Analysis** function to perform structural analyses for:

- cantilever beams (1 bearing point) and
- single-span beams (2 bearing points).

**Please note:**
The selection of the beam for the calculation can take place via the catalogue or by identification of a beam in your drawing. The structural cross-section values A, Wy and Iy will only be automatically entered for I-beams and U-beams.

Please note about HiCAD 2016 (2100.0):
When creating boltings via Design Variants as accessory parts (Staircase/Railing Configurator) or loose parts (Connections 2320, 2322, 2330, 1305, 1306, 1211) in a non-BOM-relevant assembly, no DSTV BOM can be written, because the superordinate part is missing. This can be avoided for the mentioned connections by activating the Assignment: Assembly option on the Boltings tab of the corresponding dialogue window. Bolting structures created by the Staircase and Railing Configurator must currently be adjusted manually.

Parts of a Design Variant should never be used as referenced parts that exist multiple times - neither within only one drawing nor across different drawings. As the parts will be updated via the Design Variant, problems with the recalculation can occur if one of the parts to be updated is no longer unambiguous due to the referencing.

If a part is to be referenced, the Design Variant should be completed and then broken up. Only after the breaking up, which will make the part independent of the Design Variant, can the referencing be performed without any problems.

If there are mitre cuts, the feature logs of the processed beams will contain external references. These are - in contrast to the other Trim functions - **always active**, independent of the settings in the feature! This means that if, for instance, you rotate one of the mitred beams, both beams will **always** be adjusted when performing a feature recalculation.

*Rectangular plates*

in Steel Engineering can be inserted either as main parts, or as sub-parts of beams. Please note the following:

- **Main part**
  If this option is active, the plate will be inserted into the part structure as a main part, i.e. at the uppermost level. (1)

- **Sub-part**
  If this option is active, the behaviour depends on whether the identified beam is an assembly main part or not.

  If the identified beam is an assembly main part, the plate will be placed on the same structure level as the beam. (2)

  If the identified beam is no assembly main part, a new assembly – consisting of plate and beam – will be created, and the beam will be made the assembly main part. (3)
When inserting bolts in an auto-generated assembly in Steel or Metal Engineering, the dimensions of the assembly will be determined by the production type specified in the settings for bolts. If Site assembly has been selected, the part dimensions will not be changed by the insertion of the standard part, i.e. the dimensions will then correspond to the shipping dimensions.

(1) Steel Engineering assembly with original dimensions, (2) Insertion of an anchor bolt, (3) Dimensions of assembly after insertion of bolt with production type “Factory assembly”, (4) Dimensions of assembly after insertion of bolt with production type “Site assembly”.

Create detail drawings for selected Steel Engineering parts – Drawing frames (July 2015)

For the Create detail drawings for selected Steel Engineering parts function, the contents of the selection box for the drawing frames beneath Layout will be determined via the system file StbETZng_Rahmen.dat in the SYS directory of your HiCAD installation. Edit this file to remove superfluous drawing frames from the selection box, or add new ones to it.
The structures of the staircase guidelines DIN18065 Building staircases 1, 2, 3 and 5 are derived from one another in the ISD Configuration Editor. The key DIN18065_Gebäudetreppe n_1 is the template to which the other keys are linked. You can derive further keys with the same structure from this template key. To do this, select Steel Engineering > Products > Staircase > Guidelines and mark the DIN18065 Building staircases 1 item. Then, select Derive structure — either via the context menu (right-click) or via the Edit menu.

Instead of the key name highlighted in blue, enter the desired designation, e.g. “Nursery staircase”. If you want to copy the values of another guideline, activate the Copy values check box and select the Guideline.

The values in the derived structures can be adjusted according to the guideline for which they were created. In this way you can, for example, create special guidelines for special staircases and have them offered for selection in the Staircase Configurator.
The generation of staircases and railings with the Staircase/Railing Configurator can only be performed if your drawing contains a main assembly!

A main assembly is a special assembly to which all other assemblies and parts of a drawing are subordinated. Each drawing can contain only one main assembly.

For 3-D drawings, HiCAD offers an option in the Start Centre enabling you to define the drawing file as an assembly drawing directly during its creation and enter it into the HELIOS database (if available). This makes working processes more efficient, most notably referencing, itemisation, BOM generation, or a combined utilisation of the PDM system HELIOS. If a 3-D assembly drawing is selected, a 3-D main assembly will be automatically created, and all subsequently created 3-D assemblies and parts will be subordinated to it. Main assemblies are used in many automatisms. During itemisation and identical part search in Steel Engineering, for example, the product structure of the main assembly, including its sub-assemblies, will be automatically transferred to the HELOS product structure.

In the ICN, 3-D main assemblies are shown with the symbol.

To create an empty main assembly manually, select 3-D Standard > New > Assy. > Main assembly.

To form a main assembly of already existing parts of a drawing, mark the desired parts in the ICN, right-click the selection and choose Form assembly. This “normal” assembly can then be converted to a main assembly: Right-click the assembly and select Part/assembly structure > Change part – Into main assembly.

Assemblies can be aligned in workshop drawings in Fitting position (“ready-to-use position”) or in Processing position.

This enables you to create drawings both for overview and processing purposes.

Please note that this setting will only be considered for assemblies with a Steel Engineering main part!

The exchanging of beams and profiles by means of the function Steel Engineering > Further functions > Exchange is not supported for curved beams/profiles and for beams/profiles that have been created along a guideline. If you select such beams/profiles, the function will be rejected, an a corresponding message will be displayed.
If the tabs of a Design Variant dialogue window are not immediately visible after an update of HiCAD, click the Reset icon in the Configuration area of the window.

Then, close the window and call the variant again.

Steel Engineering - Leader lines for part annotations in workshop drawings (NL 3/2013)

Select Steel Engineering > Further functions > Settings >... > Part annotations... to specify the appearance of the annotation tags for various parts. In the Annotation Editor, the leader lines of annotations can be shown or hidden by activating or deactivating the corresponding checkbox. For generated workshop drawing, however, the deactivation has no effect. Here, the annotation tags are always created with leader line. The setting will be ignored, to enable the annotation tags to always appear with leader lines in workshop drawings.

Steel Engineering - Lengthen beams (NL 1/2013)

The functions that are available in the Lengthen function group on the Steel Engineering tab always lengthen/shorten the beam while retaining the geometry of the existing front contour to be moved. This means that no surfaces are changed, removed or added on the front contour. For example, the shortening of a beam will fail if the beam is to be shortened in such a way that its front intersects with a bore (see image below).

Example: (1) Identified beam, (2) Value for the change of length

In such situations, use the Trim function instead, as it enables a genuine cutting of the beam to the selected surface/edge, independent of the existing geometry (processings in the front contour can also be applied beforehand).

Management + BIM

Management of mounting Drawings (BIM) (January 2017)

Besides production drawings you can now also create, update and manage Mounting drawings with the functions of the Management+BIM tab. For this you use the Mounting drawing function at Management+BIM > Drawing... . The function works in the same way as the same-named function found at Drawing > Itemisation/Detailing..., with the difference that it directly assigns the relevant HELIOS links to the drawings. (as of HiCAD 2016 SP2)
This document attribute `CONSTRUCTION_SECTION` allows a marking of assemblies as construction sections. If this attribute has been assigned to an assembly via the document master, all parts belonging to this assembly will obtain the `Construction section` link. In this way you can check at any time to which assembly a part belongs. The supplied document masks do not contain this attribute by default. If you want to use it, you need to expand the mask accordingly with the Mask Editor. (as of HiCAD 2015 SP1)

From HiCAD 2016 SP2 onwards, new dialogue masks for Document and Drawing Management in Civil Engineering are available. These contain, for instance, the attribute `CONSTRUCTION_SECTION` (Documents and Articles).

See also Online Help

Important information about settings for BIM (Nov. 2015)

If using BIM, it is currently necessary to deactivate the option shown in the following screenshot:

If this option is not deactivated, it is possible to find problems about released parts.

In the following versions (2002.2 and newer) this value will be added to the BIM template; if running `ParKonfigComp` with activated BIM option, the value will be set “correctly”.

Steel Engineering Drawing Management

When using the Steel Engineering Drawing Management module, please note that you must be a member of the Groups SEMI-FINISHED PRODUCTS and STANDARDS.

PDM in HiCAD

Activate/Deactivate PDM Project (NL 6/2012)

If you use the PDM functionality in HiCAD, you should bear the following in mind when working with Projects:
• The activating or deactivating of projects in HiCAD has no effect on the settings in the HEliOS Desktop, i.e. the project will only be active/inactive in HiCAD (but not automatically in the HEliOS Desktop as well). Of course, this also applies to the reverse case, i.e. the activating/deactivating of projects in the HEliOS Desktop only takes effect in the HEliOS Desktop, but not in HiCAD.
• After restarting HiCAD, the project that was last activated in HiCAD will be suggested as the active project in the PDM login window. If you want to activate a different project or work project-independent, you can change the settings already in the login window accordingly. For a subsequent change in HiCAD you can use the functions in the Project function group on the HEliOS PDM tab. For example, if you want to activate a different project, select the **Activate/Edit project** function.

If you want to work project-independent, use the **Deactivate project** function.

**Loading from the HEliOS product structure (NL 6/2009)**

Assuming you want to insert a part into your drawing, but cannot remember the name of the part in HEliOS. You do however remember the name of the machine or assembly to which the part belongs. In this case you can use the HEliOS product structure to retrieve the part. First, proceed as follows in HiCAD:

• On the Drawing tab, select **Insert Part > Parts/Variants > Via master part**.
• The HEliOS search mask is displayed. Now search for the machine or the assembly to which the part you are looking for belongs.
• In the result list, click the appropriate entry. In the upper area of the window a part mask is added to the search masks. This part mask contains the Product structure tab.
• Open the **Product structure** tab and right-click the part you are looking for. Select the **Display part** function.
• In the displayed window, click the **Links** or the **Link docu.** tab. Right-click to open the context menu and select the **Load document** function to insert the part into the HiCAD drawing.

**Interfaces/Converter**

**STL format (October 2015)**

For the import of STL files, HiCAD only supports text-based (ASCII) files. The import of binary STL files in HiCAD is not possible.

For the export, in contrast, HiCAD supports both formats, and you can select whether you want to create an ASCII file or a binary file.

**STEP export (NL July 2014)**

When exporting HiCAD drawings to 3-D formats, e.g. STEP, the SSWRITESTEP.DAT file will no longer be evaluated. The setting options contained in this file have been moved to the **Configuration Editor**, at Interfaces > General 3-D interfaces. (as of HiCAD 1901)

**DSTV-NC export – Processings on beams with circular cross-sections (NL 4/2014)**

Processings on beams and profiles with circular (i.e. “infinite”) cross-sections are not written out for exports via DSTV-NC interface. For these beam and profile types, only the header data will be written.

**Save 3D-DXF, approximative (NL 5/2013)**

When you save an approximative 3D-DXF file (Drawing > Save/Print > Save as > ... > Interfaces > Further > 3-D DXF (Approx.),) the DXF file will be saved to the HiCAD directory “Szenen” (or the C: path defined in the FILEGRUP.DAT file, respectively) without any further queries.

**DXF and CAM: Adjust settings (NL 2/2009)**

**Problem:** A DXF file created with HiCAD default settings cannot be read by a CAM system with a relatively old interface.

**Solution:** The editing of the HCADACAD.DAT file in the SYS directory of the HiCAD installation and the changing of the following parameters will normally lead to success:
Plant Engineering/Pipeline Isometry

Plant Engineering: Take pipeline name from P+ID (July 2017)

When creating a new pipeline with the Create pipeline function, the name of the pipeline will be taken from the P+ID if a pipe class is assigned from the P+ID (as of HiCAD 2017 SP1).

Plant Engineering – Merge pipelines (January 2017)

Use the new Merge pipelines function to combine several pipelines into one pipeline. You can find the function at Plant Engineering > Pipeline Tools > Change > ... (as of HiCAD 2016 SP2).

Click here for further information.

Plant Engineering – List of current part variants (Mar 2015)

HiCAD currently offers more than 800 Plant Engineering part variants which can be found in the in the PLANTPARTS subdirectory of the HiCAD installation. To obtain detailed information on a variant, open the corresponding VAA file with the HiCAD Variant Editor.

A list of the current Plant Engineering part variants – in German, English, French, Italian and Polish language – can be found here.

Referenced pipeline (NL August 2014)

Referenced pipelines will be saved automatically (i.e. without any further queries) when the isometry is generated. In contrast to all other elements in HiCAD, the layout plan will always be saved after confirmation of a security prompt.

Pipeline Isometry – Freely definable margins in drawing frames (NL 6/2010)

As of Version 1502.2, you can individually define the drawing frame areas used by pipeline isometries. This enables e.g. the creation of asymmetrical filling margins etc. The determination takes place via definition of a hidden frame called INNER within the drawing frame figure.

Proceed as follows:

- Create a new drawing a 1:1 scale.
- Load the drawing frame to want to change, e.g. DIN A4H (A4, portrait). Right-click the drawing area and select the Insert drawing frame function in the context menu.
- Drawing frames are auxiliary drawing parts and are normally not shown in the ICN. If
the drawing frame does not appear in the 2-D tab of the ICN, right-click the name of the drawing in the ICN, and select the **Auxiliary parts On/Off** function. In the dialogue window, click the **Auxiliary parts On** button. The drawing frame will then appear in the 2-D part structure of the ICN.

- In the 2-D part structure, right-click the name of the drawing frame, e.g. DINA3, and select the New sub-part (2-D) function in the context menu. Assign the name INNER to the part.
- Use the functions on the 2-D Geometry tab to draw the desired area.
- Assign Level 0 to the part INNER. This is necessary to make these sub-parts invisible. In this way, the drawing frame will remain utilisable for other HiCAD modules as well.
- To change the level, right-click the corresponding part, select the **Change level** function and set the level to 0.
- Save the changed drawing frame. Right-click the name of the drawing frame, e.g. DINA3, select the **Save part (2-D)** function. Select the options **Save as 2-D part and Without database**. Target directory is the HiCAD sub-directory SZENEN (=DRAWINGS). You can now use the changed frame for the isometry.

**Please note:** As a precaution, save the original drawing frames. Also create back-ups of the changed drawing frames, in order to prevent an accidental overwriting when making updates or new installations.

### API

**Keyboard shortcuts for scripts (NL 11/2012)**

The following keyboard shortcuts are available for the API:

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL + J</td>
<td>Start Script</td>
</tr>
<tr>
<td>CTRL + H</td>
<td>Call Script Editor</td>
</tr>
</tbody>
</table>

Furthermore, numerous other keyboard shortcuts for many other areas are available.

As a customer you can find an overview of the shortcuts in the Online Help.

### System/Hardware

**License Server (NL July 2014)**

The license server **must not** be installed on the same computer on which an ISD software product (HiCAD, HELiOS) is installed, as both product share system data concerning the licensing information!!

**Checking the HiCAD-capability of your graphics card (NL 4/2011)**

For HiCAD 2010 and HiCAD 2011 you require a fully OpenGL 2.0-capable graphics card with a memory of at least 128 MB. You can use the **OpenGLCapabilityTester** to check whether the OpenGL capability of your card is sufficient for HiCAD.

**Recognition of operating system version (32/64Bit) while AutoStart function is switched off (NL 4/2011)**

If the AutoStart function has been switched off in the operating system, it is mandatory for the installation of HiCAD 2011 to start the file “setup.bat” from the main directory of the DVD. Only in this way it is ensured that the version of the operating system (32/64Bit) will be recognized correctly, and that the matching HiCAD/HEliOS version will be installed.

**HiCAD 2011 can only be executed as a new installation (NL 2/2011)**

HiCAD 2011 can only be executed as a new installation, another installation directory than the one for the previous version must be used. If changes or amendments have been made to the standard part catalogue of the previous version, a “manual” adjustment of the standard parts catalogue will be required.

First check if the reference in the registry has been set to the “correct” catalogue directory (the
directory is specified in the CatDir variable in the key HKEY_LOCAL_MACHINESOFTWAREI
SD Software und SystemeHiCAD[Version number]).

Start the CatalogueUpdate program in the exe directory of the HiCAD installation and enter
the previous version in the corresponding field (after new installation there will be a 0); specify
the directory [Programm/Programm64]hicad3.catKataloge on the installation DVD as update
source.

The ISD recommends creating a backup of the catalogue directory before each
catalogue update!

---

#### Incompatible DLLs (NL 1/2011)

Some programs (e.g. snapshot utilities) install DLL files which are automatically loaded when a
program is started. Incompatible DLLs can prevent or abort the start of HiCAD. To verify
whether such DLLs exist, check the key

HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows NT > CurrentVersion >
Windows

or, for 32Bit HiCAD on 64Bit Windows,

HKEY_LOCAL_MACHINE > SOFTWARE > Wow6432Node > Microsoft > Windows NT >
CurrentVersion > Windows

in the registry.

If the variable AppInit_DLLs is followed by an entry, this DLL will be loaded at each program
start. This can be prevented by either deleting the value of the variable (only the value, not the
variable!), or setting the value of the variable LoadAppInit_DLLs to 0.

---

#### Which settings should be applied for Nvidia graphic cards? (NL 5/2009)

If required, the default settings should be changed as follows:

- **Vertical synchronisation --> Always OFF** This setting influences the image buildup
  speed.
- **Shared background/Z-buffer --> OFF** As of HiCAD neXt 2008 this setting will be
  required to prevent errors in the graphics.

In newer drivers these settings are automatically applied if the HiCAD application profile is
used in the driver!

---

#### HiCAD/HELiOS installation via network connection (NL 3/2009)

HiCAD/HELiOS can be installed via a network connection, the installation files need however
be provided to the client via a network drive connection; connections via UNC paths are
insufficient.

---

#### HiCAD/HELiOS on 64Bit Windows (NL 3/2009)

The programs and tools for HiCAD and HELiOS can be utilised, without requiring any special
settings, on a 64Bit operating system. Please note however that the ODBC data source for
HELOIS needs to be set up via the ODBCAD32.exe program in the SysWOW64 directory of
the Windows installation. If you use the functionality from the Control Panel, the data source is
not found.