Skip to end of metadata
Go to start of metadata

Alles einblenden/ausblenden - Expand/Collapse All  

 


Tips&Tricks 2018

 Product structure: Switch item (December 2018)

As of HELiOS 2018 SP1 the context menu for items now contains the  Switch item function.

Use this function to switch an article of an item for another item. When you call the function the Find article dialogue window will be displayed. Here, choose the required article (a search for a concrete index is also possible here). Confirm to exchange the article.   Please note that the function considers the settings for the Database option Allow updating of released product structures.

Extensive information can be found in the Online Help.

 HELiOS - Remote Maintenance (November 2018)

When you install HELiOS 2018 (as of SP2 Patch 1), the Support tool TeamViewerQS.exe will now automatically be installed (in the sub-directory Remotesupport of your HELiOS Installation).In case of problems that require support by the ISD Group, you have the option to call the TeamViewer tool from HELiOS.

For a quick start of the tool, choose the Remote Maintenance function in the Help menu. Please note however that you should only use this tool if you have been requested to do so over the phone by staff members of our Helpdesk.

After calling the function, you need to confirm the Windows security prompt, asking you whether you want to allow changes to your system by the tool.The TeamViewer will then automatically generate an ID and a Password, which may take some seconds.Let the support team member of the ISD Group have the ID and the Password to allow the remote access to your computer.

 

Important notes on using the Remote Maintenance tool and on protection of your data:

  • To be able to use Remote Maintenance you require an active online connection.
  • During the Remote Maintenance you can see what we do on your computer.
  • With the ID and the Password that you give to our Helpdesk, remote access to your computer will only be possible once.
  • All data, information or other knowledge that our Helpdesk obtains during the Remote Maintenance session, will neither be disclosed on third parties, nor used in any different way by us.
  • The TeamViewer is a product of the TeamViewer GmbH, Jahnstr. 30, 73037 Göppingen, Germany, Phone: +49 (0)7161 60692 50, E-mail: service@teamviewer.com. Further information on the TeamViewer can be found on the website of the manufacturer of TeamViewer. There you can also find all required information on the topic of data security. 
  • Please also read the Notes on Data Protection by the ISD.
  • By contacting our Helpdesk via the Remote Maintenance you confirm that you have read and understood the above notes.
 HELiOS - Combined search - Filter options (November 2018)

The behaviour of the Combined search function has been modified as of HELiOS 2018 SP2.

If you deactivate all link classes for the search, i.e. nothing has been selected in the field beneath Links, all objects matching the entered search criteria that are not linked to any other object will be shown in the corresponding result list.

In this way you can, for instance, list documents of already deleted articles in conjunction with other, attribute-related search criteria, e.g. in order to link, move or delete them.

Furthermore, you can search for articles without assigned drawing in order to determine for large assemblies whether drawings have been created for all related parts, or whether parts have been "overlooked" by mistake.

 HELiOS - Result list settings for Combined search (November 2018)

Beneath Object-specific on the Result lists tab of the HELiOS Options dialogue window you can find a new pull-down menu item called Document and Article (as of HELiOS 2018 SP2).

This setting is for the Combined search function. It allows you, for instance, to display the result lists of a combined search sorted by document numbers in ascending order by default.

 HELiOS – Marking of new indices (October 2018)

In the result list configuration you can find the new Index up-to-dateness Attribute. If an Article or a Document has a newer index, older indices will be indicated in the Index up-to-dateness column with a star Symbol .

 

Right-clicking the title of the Index up-to-dateness opens a context menu. The menu item Strategy allows you to choose between three different additional display options:

  • Newer index
    The symbol indicates that a newer index exists for the listed object, i.e. that the index of the listed object is not up to date.
  • Newer index (detailed)
    If the object is marked with the symbol, a higher (newer) index exists, but no newer released version of the object. The symbol indicates that higher and released indices exist for the listed object, but that the highest index has not been released yet. If a result list entry is marked with the symbol, this indicates that a version with a higher index with Workflow status Released exists.
  • Newer released index
     If a result list entry in the Index up-to-dateness column is marked with the symbol, this indicates that a higher index with Workflow status Released exists.

Click here for further Information.

 

 HELiOS for Inventor – Apply server state (October 2018)

In the Data function group of the HELiOS Ribbon or in the menu of the active part, you can find the Apply server state function (HiCAD 2018 SP2).

 

The Apply server state function checks whether the currently loaded document or the active document is identical with the current server state. If this is not the case- e.g. because the document has been saved by a different user in the meantime, or exists with a newer index, or because the master data of a linked article have changed or the article exists with a newer index - use this function to apply the current Server state to the document. 

 

 HELiOS interface to Autodesk Navisworks (September 2018)

As of HELiOS 2018 SP1 an interface to the design review software Autodesk Navisworks can be established.

 

This interface will give you direct access to various HELiOS functions in Navisworks.

 HELiOS: Result list button for opening of documents (June 2018)

As a faster alternative to a function selection via context menu (right-click and choose function), you have now the option to assign buttons to document result lists, allowing you to open documents in the linked application with one mouse click, either for editing or in read- only mode.

For this purpose the two attributes UI_OpenEditItem and UI_OpenItemReadOnly have been created, which just need to be activated in the result list configuration.

 

As of HELiOS 2018 Service Pack 1 these buttons are available in every result list with document context, e.g. in the Document Class Explorer, in the HELiOS Workspace, in the Targets tab of article master masks etc.

 

 HELiOS: Templete files in external folders (April 2018)

 

In the directory \HeliosMusterdateien\ of your HELiOS or HiCAD installation you find template files for the different file types of the document input. The template file controls the link between the document and the application (HiCAD, Word, Excel, ...)  

To be able use a central template file directory for multiple workstations, e.g. in order to manage them in one or several central places for different workstations in a department, you can create an .ini file in the local template file directories which refers to these directories (e.g. network drives on Servers etc.). To do this, create a file called  "TemplateExtensions.ini" in the corresponding directories.  The content of the file corresponds to the paths to be considered, e.g.:  

Files located in these folders will then be considered for the HELiOS template file selection dialogue on the local HELiOS workstations. Please ensure that file names are not assigned twice on different directories. If in doubt, clear the local directories for a central managing of the template files.

 

 Editing of attributes for combined items (March 2018)

In the product structure of the HELiOS Desktop you have now the option to combine multiple items with identical attribute values into a set on the Utilized items tab. This will then allow you to change the attributes of such combined attributes in one step (as of HELiOS 2018). To combine the items into a set, right-click an item attribute (e.g. Item number or Qty.) and choose Create set.

Items combined into a set will be marked with a “Plus” sign in the first column on the left of the result list. Clicking on the “Plus” sign breaks up the set again, turning the “Plus” sign into a “Minus” sign. Clicking the “Minus” sign creates a set again.

 

As of HELiOS 2018, a direct editing of items that have been combined into a set will be possible. If the attribute values are identical, you can edit them directly and for all items of the set (double-click the set). If the attribute values are not identical, this will be indicated in the result list by the Comment Different values. In this case you must edit the items individually.

 

Please note:

 Items with different revision indices and different CAD-relevance (i.e. items with CAD link and items without CAD link) cannot be combined into sets. When you attempt to create a set of multiple items only some of which have a CAD link, all items with CAD link and all items without CAD link will be combined into two separate sets.  

 top of page


 

Tips&Tricks 2017

 Notes on File Conversion via the Spooler - Hel_fileprint.ini (December 2017)

CAD drawings can be converted into other formats via the HELiOS Spooler, e.g. from HiCAD files (.SZA) to STEP or 3D-PDF, from SOLIDWORKS into the .TIF format, or Inventor sheet development files. 

For this you require the hel_fileprint.ini file in the sys directory of your HELiOS or HiCAD installation. This file contains the names of the files to be output as PDF files or to be converted into other file formats.

In the file the two keywords ATTR and FIX can be used: ATTR defines the document attribute to be used for the file name, and FIX defined a fixed text.

Each definition needs to be written in its own row.

 

Example:

ATTR = HEL_DOKUNUMMER

FIX = -

ATTR = HEL_BLATT

FIX = #

ATTR = HEL_INDEX

 

creates a file name consisting of document number, sheet number and index, each of which are separated by a minus sign or a hash, i.e.

[Document number]-[Sheet number]#[Index].

Via the keyword ATTR only document management attributes will be output.

 

Click here for further Information.

 HELiOS - Favourites - Displayed Index (July 2017)

If you click on the  Show objects symbol in the Favourites window, you can choose whether the objects in the Favourites window are to be displayed with the index with which they had been added, or with their highest index (if any).

The Concrete index shows the object (Document, Article, Folder, Project) with the index with which it was added to the Favourites.    

The Current state shows the objects with their highest index.  

This allows you to take a look both at the origin of objects that have changed in the meantime and their most recent state in the Favourites window.

 HELiOS - Filter for parts where-used list

The result list for the use of parts or assemblies (parts where-used lists) can now be further refined by means of user-defined filters, allowing you to retrieve relevant part even faster. (as of HELiOS 2017 SP1)
This allows you, for instance, to save search templates that will show you,

  • in which currently released assemblies a particular part with a particular index is directly or indirectly contained, or
  • in which pre-mounted facade parts a particular sealing element has been used throughout different projects.

As is the case with the combined search, article classes and links can be considered. The latter is, for instance, relevant for a filtering for mechatronical items in mechanical engineering or electrical engineering BOMs, since mechanical engineering article are normally linked to a CAD document.

 HELiOS - Export and import of settings

In older HELiOS versions, the UI settings on various workstations could be aligned and standardized by manually copying the corresponding system files to the various systems. The Export/Import mechanism facilitates this process significantly.  

From HELiOS 2017 onwards, changes to the UI of the HELiOS Desktop can be exported as ZIP packages, and re-imported on a different workstation. You can choose which changes are to be exported and imported.

 

Such changes can also be defined and distributed already during installation. In the Extended settings window of the installation mask you have the option to import a UI configuration.

 

Click here for further information.

 HELiOS MS Office Interface – Customize Ribbon (March 2017)

If interfaces between HELiOS and MS Word, Excel or Outlook have been created, you will find an additional menu called HELiOS in the respective software. It is generally possible to adjust the range of available functions of the HELiOS menu (e.g. deactivate a button). The UI settings for this can be found in the \Recources\Ribbon\OfficeUI\ directory of your HELiOS installation, where the files

  • Ribbon.Document.XML for the settings in Word and Excel, and
  • Ribbon.Explorer.XML for the settings in Outlook 

are located.

To deactivate a function in the UI, rename the switch getEnabled="(...)" beneath the Button ID of the function to enabled="false" in the corresponding system file. For instance, if you want to deactivate the function Attribute fields > New, you need to change the line getEnabled="IsCUrrentDocumentInHelios" to enabled="false" beneath <button id="BtnAttAdd" in the XML file Ribbon.Document.

The function can then no longer be accessed in the Office UI.

Please note:

XML is a Microsoft format that is not treated as a configuration by HELiOS, i.e. it may be overwritten in the course of updates, changing the structure of the relevant files in the process. No warning message will be issued.

In such cases, changes in the files will also be overwritten during HELiOS updates and must be renewed.

Improper modifications can render the HELiOS-Office interface inoperable! If you need any further information, please contact the Consulting team of the ISD.

 HELiOS - MS Office interface with expanded attribute selection

The selection dialogue for the placing of HELiOS attributes in an Office document has been adjusted to the current HELiOS Desktop standards.

As a result, a wider range of functions of attributes that can be placed in title block is available to you. This also included reference attributes such as the Material ID (Material) or Customer data.

Furthermore, you can use the filter function to search directly for specific attributes.  

Click here for further information.

 HELiOS - Admin Tools

As of HELiOS 2016 SP2 the Admin Tools tab provides direct access to  

  • the User and Workflow Management EDBSETUP, and
  • the ReleaseNext tool for listing and unlocking of locked documents.

 

Please note:

  • The Classification functions that were available on the Admin Tools tab of older versions have been removed with the introduction of the new Class Explorers.
  • The Admin Tools tab is only visible if you are logged in as an Administrator.
 HELiOS – Other export formats in the Spooler

As of HELiOS 2016 SP2 a conversion of SZA files via the HELiOS Spooler will be possible for the following target formats:  

  • IFC
  • 3D-DXF
  • 3D-DWG
  • ACIS
  • Parasolid
  • Catia V4 and Catia V5
  • ProE
  • VDAFS
  • Iges

The Set-up on the Client takes place in the system file hel_fileconvert.ini.

 top of page


 

Tips&Tricks 2016

 ToDo list - Enhanced result list filter configuration options (December 2016)

The result list filter configuration options for ToDo lists have been enhanced (as of HELiOS 2016 SP2). Here you will find a new option allowing you to display all objects created by the group of the logged-on user (i.e. not only those that were created by the user him-/herself, but also those that were created by other members of his/her group). This will also provide you with an overview of all outstanding tasks of the complete user group.

 HELiOS in HiCAD – Initialisation of article attribute values (July 2016)

When creating new article masters in HiCAD, the settings in the file Hicad-HELiOS_TS.dat (in the HiCAD sys directory) will be evaluated. If the parameter 

Apply part attributes to part master when creating new part master? 1=Yes, 0=No

is set to 1, the attributes will be applied as follows: 

Meaning

HiCAD Part attribute

HELiOS article attribute

Article number

$BB  

HEL_SACHNUMMER

Designation 1

$01  

BENENNUNG

Designation 2

$02  

BENENNUNG2

Comment

$03  

BEMERKUNG

Part type

$05  

TEILEART

Dimensions

§09  

ABMESSUNGEN

Length

§03  

LAENGE

Width

§02  

BREITE

Height

§04  

HOEHE

Weight

§01  

GEWICHT

Avoirdupois weight

§18  

HANDELSGEWICHT

Surface area

§10  

FLAECHE

Beam cut type

$06  

PROFIL_SCHNITTTYP

Beam cutting angle1

§14  

PROFIL_SCHNITW1

Beam cutting angle2

§15  

PROFIL_SCHNITW2

Beam cutting angle1   XZ

§05  

PROFIL_SCHNITW1XZ

Beam cutting angle1   YZ

§06  

PROFIL_SCHNITW1YZ

Beam cutting angle2   XZ

§07  

PROFIL_SCHNITW2XZ

Beam cutting angle2   YZ

§08  

PROFIL_SCHNITW2YZ

DIN weight/m

§16  

GEWICHT_M               

Avoirdupois weight/m

§19  

HANDELSGEWICHT_M

Surface area/m

§17  

FLAECHE_M

Moment IY

IY   

MOMENT_IY

Moment WY

WY   

MOMENT_WY

Moment IZ

IZ   

MOMENT_IZ

Moment WZ

WZ   

MOMENT_WZ

A web

ASTEG

PROFIL_ASTEG


 HiCAD Spooler: Output of ICN Names / HELiOS Attributes for 3-D Interface Exports (Jan. 2016)

If desired, you can also export the HELiOS attributes shown in the ICN when performing an (automatic) 3-D interface export (Step, 3D-PDF) via Plot Manager or the HiCAD Spooler.

For this to happen, you need to adjust the system file brw_3dinterface.hdb in the \sys\ directory of your HiCAD Spooler installation as follows:

 

HDB
# Configuration file for the output of any number of database-
# or HiCAD part attributes instaed of the part name in the 3-D browser.
# TEXT - Commentary ( will not be displayed )
# ATTR - Database attribute
# <D> - Document master data
# <T> - Part master data
# <H> - HiCAD part attribute (e.g. $BB)
# <E> - HiCAD part feature (e.g. NAME)
# _BEGIN_OR_ _END_OR_ - "ODER" link

_BEGIN_OR_
<H>::TEXT=""::ATTR="~vICN"::TYP="WCHAR"::FORMAT="%s"
_END_OR_ 

 

 top of page

  • No labels