Tipps & Tricks 2019

Falls ein Anwender eine mit HELiOS zu koppelnde Applikation in verschiedenen Versionen auf ein und demselben Rechner installiert hatte, musste man sich bei der Installation für genau eine Version entscheiden. Nun (ab HELiOS 2019 SP1)können bei der Installation mit einer Lizenz auch mehrere Versionen gewählt werden.

Im HELiOS Arbeitsbereich steht ab HiCAD 2019 die neue Spalte Lokal geändert zur Verfügung. In dieser Spalte wird durch das Symbol angezeigt, wenn ein Dokument seit dem letzten Abgleich mit HELiOS (z.B. durch Laden bzw. Speichern) lokal geändert und gespeichert wurde.

 

Darüberhinaus können Sie In den HELiOS-Optionen bestimmen, ob lokal geänderte Dokumente (falls vorhanden) beim Beenden von Inventor aus dem Arbeitsbereich entfernt werden sollen oder nicht.

 

Mit der neuen Funktion Artikelstammabgleich beim Speichern lässt sich ab HiCAD 2019 festlegen, welche HiCAD-Teileattribute beim Speichern dem HELiOS-Artikelstamm zugeordnet werden. Diese Attribute werden dann bei jedem Speichern automatisch abgeglichen.

Beachten Sie dabei, dass dazu im ISD-Konfigurationsmanagement unter Systemeinstellungen > HELiOS die Checkbox Teileattribute an HELiOS übertragen aktiv sein muss.

Sie finden die Funktion unter Konstruktion > Positionierung/Detaillierung > Attr...

Weitere Informationen

 

Die vom Anwender bei einem Wechsel des Workflowstatus eingegebenen Notizen lassen sich ab HELiOS 2019 auch in entsprechend konfigurierte und von HELiOS automatisiert versendete E-Mails integrieren. Der Empfänger der E-Mail hat damit noch schneller Zugriff auf alle benötigten Informationen und notwendigen Aktionen.

Stellen Sie dafür in der EDBSETUP-Aktionsliste des entsprechenden Workflowschrittes für die Aktion E-Mail verschicken den Attribut-Platzhalter <$EDBNOTE> mit ein, der den Notiz-Kommentar in die E-Mail übernimmt. 

Microsoft® stellt im Januar 2020 den Support für das Betriebssystem Windows® 7 ein. Daher werden aus Kompatibilitätsgründen HiCAD 2020 SP2 und HELiOS 2020 SP2 die letzten Versionen unseres CAD- bzw. PDM-Systems sein, die Windows© 7 unterstützen. Auch die entsprechenden Server-Betriebssysteme (Windows Server 2008 R2 und älter) werden dann nicht mehr unterstützt.

Ab HiCAD 2019 lassen sich Bildformate wie JPEG, TIF, BMP, PNG, etc., die als Dokumente in HELiOS gespeichert sind, durch den neu integrierten Grafikviewer von HELiOS darstellen.Sie können jederzeit in die Grafik zoomen und den entsprechenden Ausschnitt verschieben. Dies ermöglicht eine einfache Darstellung von Neutralformaten und reduziert die Anzahl an evtl. benötigten externen Viewer-Applikationen.

Ähnlich zur Office-Kopplung oder den Multi-CAD-Kopplungen ist für den HELiOS Desktop ebenfalls ein Arbeitsbereich eingeführt werden. Dokumente, die über den HELiOS Desktop und ohne Kopplung geöffnet oder bearbeitet werden, werden im Arbeitsbereichsverzeichnis abgelegt. Damit haben Sie jederzeit einen Überblick über die entsprechenden Dokumente und können Sie nach eigenem zeitlichen Ermessen in HELiOS einchecken. Beim Beenden des HELiOS Desktops erscheint ggf. eine Nachfrage zum Umgang mit Objekten im Arbeitsbereich.

Unterschiedliche Attributbelegungen von zusammengefassten Positionen in der Ergebnisliste für die verwendeten Positionen werden seit HELiOS 2018 entsprechend gekennzeichnet. Sind die Attributbelegungen identisch können Sie diese direkt und für alle zusammengefassten Positionen in der Ergebnisliste editieren.

 

zum Seitenanfang


Tipps & Tricks 2018 

Im Kontextmenü von Positionen finden Sie (ab HELiOS 2018 SP1) die Funktion Position tauschen .

 

Mit dieser Funktion lässt sich ein der Position zugrunde liegender Artikel gegen einen anderen Artikel (inkl. Auswahlmöglichkeit für den konkreten Indexstand) tauschen. Dazu wird nach dem Aufruf der Funktion die Artikelsuche gestartet. Beachten Sie, dass die Funktion die Einstellung der Datenbank-Option Bearbeiten von freigegebenen Produktstrukturen erlauben berücksichtigt.

Eine ausführliche Beschreibung finden Sie in der Online-Hilfe

Bei der Installation von HELiOS 2018 (ab SP2 Patch 1) wird jetzt automatisch auch das Supporttool TeamViewerQS.exe installiert (im Unterverzeichnis Remotesupport Ihrer HELiOS Installation). Über dieses Tool können Sie bei Problemen unserem Supportteam die Fernwartung erlauben. Dies kann insbesondere für Kunden mit schwer zu diagnostizierenden Problemen sinnvoll sein.

Für den schnellen Start des Tools steht in HiCAD im Menü die Funktion Fernwartung zur Verfügung. Dies sollte von Ihnen ausschließlich nach telefonischer Aufforderung durch Mitarbeiter/innen unseres Helpdesk eingesetzt werden. Nach dem Aufruf der Funktion müssen Sie ggf. zunächst die Windows-Sicherheitsabfrage bestätigen. Anschließend generiert der TeamViewer automatisch eine ID und ein Kennwort. Dieser Vorgang kann ein paar Sekunden in Anspruch nehmen. ID und Kennwort teilen Sie dann im Problemfall dem jeweiligen Mitarbeiter unseres Helpdesk zur Verfügung, um die Fernwartung zuzulassen.

 

 

  • Zur Nutzung der Fernwartung ist eine bestehende Onlineverbindung erforderlich.
  • Während der Fernwartung ist für Sie sichtbar, was wir auf Ihrem System tun
  • Mit der ID und dem Kennwort, das Sie unserem Helpdesk mitteilen, ist nur ein einmaliger Zugang zu Ihrem System möglich.
  • Sämtliche Daten, Informationen oder anderes Wissen, das unser Helpdesk während der Fernwartung über Ihr System erhalten, werden wir weder weitergeben noch anderweitig nutzen
  • Der Teamviewer ist ein Produkt der TeamViewer GmbH, Jahnstr. 30, 73037 Göppingen, Tel.: +49 (0)7161 60692 50, Email: service@teamviewer.com. Weitere Informationen zum TeamViewer entnehmen Sie bitte der Website des Herstellers. Dort finden Sie auch sämtliche Details zum Thema Sicherheit.
  • Bitte lesen Sie auch die Datenschutzerklärung der ISD.
  • Mit Aufnahme der Verbindung mit unserem Helpdesk über die Funktion Fernwartung bestätigen Sie, die obigen Hinweise gelesen und anerkannt zu haben.

In HELiOS 2018 SP2 ist das Verhalten der Kombisuche (Suche > Kombinierte Suche: Artikel und Dokumente)  angepasst worden.

Wenn Sie zur Suche alle Verknüpfungsklassen deaktiviert haben, d.h. im Auswahlfeld unter Verknüpfungen (rechts oben im Menüfenster) nichts ausgewählt ist, dann werden in der entsprechenden Ergebnisliste alle Objekte mit den eingegebenen Suchbedingungen angezeigt, die mit keinem anderen Objekt verknüpft sind.

So können beispielsweise Dokumente von mittlerweile gelöschten Artikeln in Kombination mit weiteren attributbezogenen Suchkriterien aufgelistet werden, etwa um diese neu zu verknüpfen, zu verschieben oder zu löschen.

Darüber hinaus können Sie z.B. auch nach Artikeln ohne Zeichnung suchen und so bei größeren Baugruppen feststellen, ob für alle Teile einer Baugruppe Zeichnungen erstellt oder Bauteile übersehen wurden.

Mit HELiOS 2018 SP2 ist In den HELiOS-Optionen (> HELiOS Optionen) sind die Einstellungen für Ergebnislisten erweitert worden. Dort finden Sie in der Auswahlbox unter Objektspezifisch den neuen Menüeintrag Artikel / Dokumente (Kombi).

Dieser greift speziell für die Kombisuche (Suche > Kombinierte Suche: Artikel und Dokumente). Beispielsweise ist es damit möglich, dass die Ergebnisse einer Kombisuche standardmäßig nach aufsteigender Dokumentnummer sortiert werden.

Liegt zu einem Dokument oder Artikel ein aktuellerer Index vor, wird dies im Feld Indexaktualität älterer Indexstände mit einem Stern-Symbol  angezeigt.

Mit einem Rechtsklick auf die Überschrift der Spalte können Sie dann im Kontextmenü mit der Funktion Strategie außerdem noch zwischen drei verschiedenen Anzeigeeinstellungen wählen:  

  • Neuer Index Es wird mit einem gekennzeichnet, dass ein aktuellerer Index zum gelisteten Objekt verfügbar ist, welches somit in einem veralteten Indexstand vorliegt.  
  • Neuerer Index (detailliert) Ist das Objekt mit  gekennzeichnet, liegt ein neuerer Indexstand, aber keine neuere freigegebene Version des Objekts vor. Das Symbol  zeigt an, dass zum gelisteten Objekt höhere Indexstände mit Freigaben vorliegen, der höchste Indexstand aber noch nicht freigegeben ist. Zu einem mit   gekennzeichnetem Ergebnislisteneintrag liegt eine Version im höheren Index mit Workflowstatus Freigegeben vor.  
  • Neuerer freigegebener Index Zu einem unter Indexaktualität mit  gekennzeichnetem Ergebnislisteneintrag liegt ein höherer Index mit Workflowstatus Freigegeben vor.

Weitere Informationen finden Sie hier

 

In den integrierten HELiOS Ribbons von Inventor steht jetzt für alle Dokumente die Funktion Serverstand aktualisieren zur Verfügung.

Mit dieser Funktion können Sie geladene Dokumente per Knopfdruck auf den aktuellen Serverstand bringen, um z. B. Änderungen eines anderen Konstrukteurs direkt und ohne erneutes Laden zu übernehmen.  

 

Mit der Auslieferung des HELiOS 2018 Service Packs 1 steht nun auch eine HELiOS-Kopplung zur Projektprüfungs-Software Autodesk Navisworks zur Verfügung. 

In dieser stehen Ihnen dann, parallel zu AutoCAD, Inventor oder MS Office, HELiOS-Menüs zur Verwaltung Ihrer Dokumente zur Verfügung.

Dokument-Ergebnislisten lassen sich jetzt Buttons zuweisen, über die Sie Dokumente zur Bearbeitung oder schreibgeschützt in der verknüpften Anwendung mit nur einem Klick öffnen können. Dies erspart den Funktionsaufruf über das Kontextmenü.

Dazu stehen ab HELiOS 2018 SP1 die Attribute

  • UI_OpenEditItem und
  • UI_OpenItemReadOnly

zur Verfügung, die Sie einfach nur in der Ergebnislistenkonfiguration aktivieren müssen.

 

Die die Buttons stehen in jeder Ergebnisliste mit Dokumentkontext zur Verfügung, z.B. im Dokument-Klassenexplorer, im HELiOS Arbeitsbereich, im Reiter Ziele einer Artikeldetailmaske usw.

 

Im Verzeichnis \HeliosMusterdateien\ Ihrer HELiOS- bzw. HiCAD-Installation liegen Musterdateien für die verschiedenen Dateitypen der Dokumenteingabe. Die Musterdatei steuert die Verknüpfung zwischen Dokument und Anwendung (HiCAD, Word, Excel, ...).

Um ein zentrales Verzeichnis von Musterdateien für mehrere Arbeitsplätze zu nutzen, z.B. um sie an einer oder mehreren zentralen Stellen für mehrere Arbeitsplätze einer Abteilung zu verwalten, kann in den lokalen Musterdatei-Verzeichnissen eine .ini-Datei angelegt werden, die auf diese Verzeichnisse (etwa Netzlaufwerke auf Server etc.) verweist. Legen Sie dafür in den entsprechenden Verzeichnissen eine Datei namens TemplateExtensions.ini an. Der Inhalt der Datei entspricht den Pfaden, die berücksichtigt werden sollen, z.B.:  

Dateien, die in diesen Ordnern liegen, werden daraufhin im HELiOS-Auswahldialog von Musterdateien am lokalen HELiOS-Arbeitsplatz mitberücksichtigt. Dabei sollten Sie darauf achten, dass Dateinamen auf verschiedenen Verzeichnissen nicht doppelt vergeben werden. Im Zweifelsfall sollten Sie bei einer zentralen Verwaltung der Musterdateien die lokalen Verzeichnisse leeren.

In der Produktstruktur des HELiOS Desktop lassen sich in der Ergebnisliste für verwendete Positionen Positionen mit identischer Attributbelegung zusammenfassen. Der Vorteil: Die Attribute zusammengefasster Positionen können in einem Schritt geändert werden (ab HELiOS 2018).

Die Zusammenfassung von Positionen erfolgt über das Kontextmenü, das Sie mit einem Rechtsklick auf ein Positionsattribut (z.B. Position oder Anzahl) aktivieren. Dort finden Sie die Funktion Positionen zusammenfassen.

Zusammengefasste Positionen werden in der ersten Spalte der Ergebnisliste mit einem Plus-Zeichen markiert. Ein Klick auf das Plus-Zeichen hebt die Zusammenfassung auf und die entsprechenden Zeilen werden durch ein Minus-Zeichen gekennzeichnet. Ein erneuter Klick auf ein Minus fasst die entsprechenden Positionen wieder zusammen.

Ab HELiOS 2018 ist nun auch eine direkte Bearbeitung von zusammengefassten Positionen möglich. Sind die Attributbelegungen identisch, können Sie diese direkt und für alle zusammengefassten Positionen in der Ergebnisliste editieren (Doppelklick auf die zusammengefasste Position).

Sind die Attributbelegungen nicht identisch, dann wird dies in der Ergebnisliste durch die Bemerkung Ungleiche Werte entsprechend gekennzeichnet. In diesem Fall müssen Sie die Einzelpositionen editieren.

 

Nicht zusammengefasst werden können Positionen verschiedener Indexstände und unterschiedlicher CAD-Relevanz. Letzteres bedeutet, dass sich Positionen mit und Positionen ohne CAD-Verknüpfung nicht zusammenfassen lassen. Versuchen Sie mehrere Positionen zusammenzufassen, von denen nur einige eine CAD-Verknüpfung besitzen, dann werden  jeweils die Positionen mit und die ohne CAD-Verknüpfung zusammengefasst. 

 

 zum Seitenanfang


Tipps & Tricks 2017

CAD-Konstruktionen lassen sich über den HELiOS-Spooler in andere Formate konvertieren, z.B. von HiCAD-Dateien (.SZA) zu  Step oder 3D-PDF, aus SOLIDWORKS in das Tif-Format oder als Inventor-Blechabwicklung. 

Dazu wird u.a. die Datei Hel_fileprint.ini im sys-Verzeichnis der HELiOS- oder HiCAD Installation benötigt. Diese Datei enthält die Namen der Dateien, die als PDF-Dateien ausgegeben oder in andere Dateiformate konvertiert werden soll.

In der Datei können die beiden Schlüsselwörter ATTR und FIX verwendet werden: ATTR definiert das für den Dateinamen zu verwendende Dokument-Attribut, FIX gibt einen festen Text an.

Jede Definition muss in eine eigene Zeile geschrieben werden.

Beispiel:

ATTR = HEL_DOKUNUMMER

FIX = -

ATTR = HEL_BLATT

FIX = #

ATTR = HEL_INDEX

...erzeugt einen Dateinamen, der aus Dokumentnummer, Blattnummer und Index besteht, die jeweils durch ein Minus bzw. ein Hash getrennt sind, d.h.

[Dokumentnummmer]-[Blattnummer]#[Index].

Über das Schlüsselwort ATTR werden ausschließlich Attribute der Dokumentverwaltung ausgegeben.

Weitere Informationen finden Sie hier.

Verschiedene Erweiterungen in 2017 SP2 des HELiOS Desktop ermöglichen Ihnen das einfache Einblenden von Attributen verknüpfter Objekte in Masken oder Ergebnislisten.

Beispielsweise können mit dem neuen "Kombi-Reiter" für Artikel/ Dokumente im Kontext des Projekt- oder Mappenexplorers verknüpfte Artikel und Dokumente in einer Zeile angezeigt werden.

 

Zwei neue virtuelle Attribute der Ergebnislistenkonfiguration zeigen die Projekt- und Mappenzugehörigkeiten von Objekten in Artikel- oder Dokumentergebnislisten an.

 

Mit Hilfe des Maskeneditors lassen Sich darüber hinaus Artikel-Datenfelder in Dokument-Masken und Dokument-Datenfelder in Artikel-Masken anlegen, um Attribute verknüpfter Objekte in (Detail-)Masken anzuzeigen.

Dies geschieht mit der Kontextmenüfunktion Neues Artikel-Datenfeld (für Dokument-Masken) bzw. Neues Dokument-Datenfeld (für Artikel-Masken).

 

Ausführliche Informationen finden Sie in der HELiOS Online-Hilfe.

Im Favoriten-Fenster können Sie nach einem Klick auf  Anzeige der Objekte auswählen, welcher Indexstand der Objekte im Favoriten-Bereich angezeigt werden soll. (ab HELiOS 2017 SP1)

Der konkrete Stand zeigt das Objekt (Dokument, Artikel, Mappe, Projekt) in dem Indexstand an, in dem es zu den Favoriten hinzugefügt wurde. Aktueller Stand zeigt die Objekte in ihrem höchsten Index an.

So lässt sich im Favoritenfenster sowohl der Ursprung von Objekten nachvollziehen, die sich zwischenzeitlich geändert haben, als auch ihre aktuellste Version.

Die Ergebnisliste zur Auflistung der Verwendung eines Bauteils oder einer Baugruppe lässt sich ab HELiOS 2017 SP1 durch benutzerdefinierbare Filter weiter einschränken. Relevanten Verbauungen können somit noch schneller gefunden werden.
So können Sie z.B. Suchvorlagen speichern, die ausgeben,

  • in welchen aktuell freigegebenen Baugruppen ein bestimmtes Einzelteil mit welcher Revision direkt oder indirekt verbaut ist, oder
  • in welchen bereits vormontierten Fassadenteilen projektübergreifend ein bestimmtes Dichtungsprofil eingesetzt wurde.

Wie bei der Kombi-Suche können auch Artikelklassen und Verknüpfungen berücksichtigt werden. Letzteres ist z.B. relevant für die Filterung nach mechatronischen Positionen in einer mechanischen bzw. elektrischen Stückliste, denn mechanische Artikel sind in der Regel mit einem CAD-Dokument verknüpft.

In früheren HELiOS-Versionen konnten Oberflächeneinstellungen an verschiedenen Arbeitsplätzen zur Vereinheitlichung angeglichen werden, indem entsprechende Systemdateien manuell auf die jeweiligen Systeme kopiert wurden. Der Export- / Import-Mechanismus vereinfacht diesen Vorgang inzwischen.

Änderungen an der Benutzeroberfläche des HELiOS Desktop lassen sich ab HELiOS 2017 als ZIP-Paket exportieren und auf einem anderen Arbeitsplatz wieder importieren. Dabei können Sie gezielt entscheiden, welche Änderungen exportiert bzw. importiert werden sollen.

Derartige Änderungen lassen sich auch im Rahmen der Installation vorgeben bzw. verteilen. Im Fenster Erweiterte Einstellungen der Installationsmaske gibt es die Möglichkeit, eine UI-Konfiguration zu importieren.

Ausführliche Informationen finden Sie in der HELiOS Online-Hlfe.

Grundsätzlich ist es möglich, den Funktionsumfang des HELiOS-Menüs anzupassen, z.B. Deaktivieren von Schaltflächen. Die Oberflächeneinstellungen dafür finden Sie im Verzeichnis \Recources\Ribbon\OfficeUI\ Ihrer HELiOS-Installation. Dort liegen die Dateien 

  • Ribbon.Document.XML für die Einstellungen in Word und Excel und
  • Ribbon.Explorer.XML für die Einstellungen in Outlook.  

Um eine Funktion in der Oberfläche zu deaktivieren, muss in der entsprechenden Systemdatei der Schalter getEnabled="(...)" unter der Button ID der Funktion auf enabled="false" umbenannt werden. Wollen Sie z.B. die Funktion Attribut-Felder > Neu deaktivieren, muss in der XML-Datei Ribbon.Document unterhalb von <button id="BtnAttAdd" die Zeile getEnabled="IsCUrrentDocumentInHelios" in enabled="false" geändert werden.

Die Funktion lässt sich in der Office-Oberfläche dann nicht mehr anklicken.

Dabei ist zu beachten:

Bei den XML-Dateien handelt es sich um ein Microsoft-Format, das von HELiOS nicht als Konfiguration behandelt wird. Das heißt, dass die Dateien bei Updates unter Umständen überschrieben werden und sich die Struktur der Datei (unangekündigt) ändern kann.

Das bedeutet u.a., dass etwaige Änderungen in den Dateien nach HELiOS-Updates u.U. überschrieben werden und erneut vorzunehmen sind. Grundsätzlich ist es außerdem möglich, die HELiOS-Office-Kopplung durch unsachgemäße Änderungen gänzlich funktionsunfähig zu machen.

Bei Unklarheiten oder offenen Fragen sollten Sie sich daher an das ISD Consulting wenden.

Der Auswahldialog zum Einsetzen von HELiOS-Attributen in ein Office-Dokument ist in der Version 2016 dem aktuellen Standard des HELiOS Desktop angepasst worden.

Dadurch steht Ihnen auch ein größerer Umfang an Attributen zur Verfügung, die in Schriftfelder eingesetzt werden können. Dazu gehören auch Referenzattribute wie z.B. die Werkstoff-ID (Material) oder Kundendaten.

Mit der Filter-Funktion können Sie darüber hinaus direkt nach spezifischen Attributen suchen.

Weitere Information finden Sie in der HELiOS Online-Hilfe.

Ab HELiOS 2016 SP2 lassen sich über die Registerkarte Admin-Tools auch

  • die Benutzer- und Workflowverwaltung EDBSETUP sowie
  • das Tool FreigabeNext zum Auflisten und Entsperren reservierter Dokumente

direkt aus dem HELiOS Desktop heraus ausführen.

 

  • Die in früheren Versionen unter Admin-Tools aufgeführten Funktionsaufrufe zur Klassifizierung entfallen mit der Einführung der neuen Klassenexplorer.
  • Die Registerkarte Admin-Tools ist nur sichtbar, wenn Sie als Administrator eingeloggt sind.

Die Konvertierung von SZA-Dateien über den HELiOS Spooler ist ab HELiOS 2016 SP2 zusätzlich für folgende Zielformate möglich:

  • IFC
  • 3D-DXF
  • 3D-DWG
  • ACIS
  • Parasolid
  • Catia V4 und Catia V5
  • ProE
  • VDAFS
  • Iges

Die Einrichtung erfolgt Client-seitig in der Systemdatei hel_fileconvert.ini.

Weitere Informationen finden Sie hier.

 zum Seitenanfang


Tipps & Tricks 2016

Mit HELiOS 2016 SP2 ist die Konfiguration des Ergebnisfilters für ToDo-Listen erweitert worden. Hier ist es jetzt auch möglich, sich Objekte anzeigen zu lassen, die von der Gruppe des angemeldeten Nutzers angelegt wurden und nicht nur vom angemeldeten Benutzer selbst. Auf diese Weise können Sie sich auch einen Überblick über alle noch  anstehenden Aufgaben der gesamten Benutzergruppe verschaffen.

Beim Neuanlegen von Artikelstämmen in HiCAD werden die Einstellungen der Datei Hicad-HELiOS_TS.dat  (im HiCAD sys-Verzeichnis) ausgewertet. Steht dort der Parameter

Teileattribute bei Neuanlage von Teilestamm in Teilestamm übernehmen 1=Ja, 0=Nein

auf 1, dann werden die Attribute wie folgt übernommen:

Bedeutung

HiCAD Teileattribut

HELiOS-Artikelattribut

Sachnummer

$BB  

HEL_SACHNUMMER

Benennung 1

$01  

BENENNUNG

Bennenung 2

$02  

BENENNUNG2

Bemerkung

$03  

BEMERKUNG

Teileart

$05  

TEILEART

Abmessungen

§09  

ABMESSUNGEN

Länge

§03  

LAENGE

Breite

§02  

BREITE

Höhe

§04  

HOEHE

Gewicht

§01  

GEWICHT

Handelsgewicht

§18  

HANDELSGEWICHT

Flaeche

§10  

FLAECHE

Profil Schnitttyp

$06  

PROFIL_SCHNITTTYP

Profil Schnittwinkel1

§14  

PROFIL_SCHNITW1

Profil Schnittwinkel2

§15  

PROFIL_SCHNITW2

Profil Schnittwinkel1 XZ

§05  

PROFIL_SCHNITW1XZ

Profil Schnittwinkel1 YZ

§06  

PROFIL_SCHNITW1YZ

Profil Schnittwinkel2 XZ

§07  

PROFIL_SCHNITW2XZ

Profil Schnittwinkel2 YZ

§08  

PROFIL_SCHNITW2YZ

DIN Gewicht/m

§16  

GEWICHT_M               

Handelsgewicht/m

§19  

HANDELSGEWICHT_M

Flaeche/m

§17  

FLAECHE_M

Moment IY

IY   

MOMENT_IY

Moment WY

WY   

MOMENT_WY

Moment IZ

IZ   

MOMENT_IZ

Moment WZ

WZ   

MOMENT_WZ

A Steg

ASTEG

PROFIL_ASTEG

Sollte es bei der (automatisierten) 3D-Schnittstellenausgabe (Step, 3D-PDF) über den Plotmanager bzw. HiCAD Spooler (der keine Verbindung zur HELiOS Datenbank hat) gewünscht sein, im ICN von HiCAD angezeigte HELiOS-Attribute mit zu exportieren, so lässt sich dies einstellen.

Hierfür muss die Systemdatei brw_3dinterface.hdb, zu finden im \sys\-Verzeichnis der entsprechenden HiCAD Spooler-Installation, wie folgt angepasst werden:

 

HDB
# Configuration file for the output of any number of database-
# or HiCAD part attributes instaed of the part name in the 3-D browser.
# TEXT - Commentary ( will not be displayed )
# ATTR - Database attribute
# <D> - Document master data
# <T> - Part master data
# <H> - HiCAD part attribute (e.g. $BB)
# <E> - HiCAD part feature (e.g. NAME)
# _BEGIN_OR_ _END_OR_ - "ODER" link

_BEGIN_OR_
<H>::TEXT=""::ATTR="~vICN"::TYP="WCHAR"::FORMAT="%s"
_END_OR_ 

  zum Seitenanfang

 

Tips & Tricks 2019 

If you work with different versions of a CAD software on the same local system, you have now (as of HELiOS 2019 SP1) the option to install the multi-CAD interface to HELiOS for each of it individually and simultaneously. For this purpose, the installation menu shows you all versions of CAD applications in a dialogue window for selection that exist in the system.

In other words: If several versions of an application exists on a system, you can choose which of them you want to interface with HELiOS.

In the HELiOS Workspace you can find the new Changed, local column (as of HiCAD 2019), where a computer Symbol indicates that a document has been changed and saved locally since the last synchronization with HELiOS.

 

 

In the HELIOS Options dialogue window you can determine whether existing, locally changed documents are to be removed from the Workspace or not when Inventor is closed. 

 

With the new function Article master sync (as of HiCAD 2019) when saving you can specify which part attributes are to be synchronized with which article master data. These attributes are synchronized automatically with each saving procedure. Please note that the Transfer part attributes to HELiOS checkbox must be activated the ISD Configuration Management via System settings > HELiOS.

You find the function via Drawing > Itemisation/Detailing > Attr...

Detailed information can be found here. 

The notes entered by users when changing a Workflow status can now be integrated into pre-configured E-mails that are automatically sent by HELiOS (as of HELiOS 2019). This instantly provides the recipient of the E-mail with all essential information and required actions.

In the EDBSETUP action list of the corresponding Workflow step, enter the placeholder <$EDBNOTE> for the into the comment field of the E-mail action dialogue window that will open when you click on the Send E-mail button. The note will then appear in the E-mail. 

 

Microsoft will cease the support for Windows by January 2020. Due to compability matters HiCAD 2020 SP2 and HELiOS 2020 SP2 will thus be the final versions of our CAD and PDM systems which support Windows ® 7.  The corresponding server operating systems (Windows Server 2008 R2 or older) will then no longer be supported either.

As of HELiOS 2019 image formats such as JPEG, TIF, BMP, PNG, etc. which have been saved as documents to HELiOS can now be displayed by the new, integrated graphic viewer of HELiOS.

You can zoom into graphics and move the selected detail at any time. This allows an easy representation of neutral formats and reduces the number of external viewers that may be required. 

 

 

As of HELiOS 2019 the Workspace that you already know from the Multi CAD and Office interfaces will be available to you in the HELiOS Desktop, too. Click on the Show workspace icon on the General Ribbon tab to open the HELiOS Workspace dialogue window.

Here, all documents of the session will be listed. Documents that are opened and/or edited via the HELiOS Desktop will be stored in the workspace directory.

This will constantly provide you with a clear overview of the corresponding HELiOS objects, so that you can check them into the database when required. When closing the HELiOS Desktop a question regarding the handling of objects that are still in the Workspace will be displayed. 

 

Different values of attributes for combined items will now be indicated in the result list for Utilized items (as of HELiOS 2018). If the assigned attribute values are identical, you can directly edit them for all combined items in the result list.

 

top of page


 

Tips & Tricks 2018

As of HELiOS 2018 SP1 the context menu for items now contains the  Switch item function.

Use this function to switch an article of an item for another item. When you call the function the Find article dialogue window will be displayed. Here, choose the required article (a search for a concrete index is also possible here). Confirm to exchange the article.   Please note that the function considers the settings for the Database option Allow updating of released product structures.

Extensive information can be found in the Online Help.

When you install HELiOS 2018 (as of SP2 Patch 1), the Support tool TeamViewerQS.exe will now automatically be installed (in the sub-directory Remotesupport of your HELiOS Installation).In case of problems that require support by the ISD Group, you have the option to call the TeamViewer tool from HELiOS.

For a quick start of the tool, choose the Remote Maintenance function in the Help menu. Please note however that you should only use this tool if you have been requested to do so over the phone by staff members of our Helpdesk.

After calling the function, you need to confirm the Windows security prompt, asking you whether you want to allow changes to your system by the tool.The TeamViewer will then automatically generate an ID and a Password, which may take some seconds.Let the support team member of the ISD Group have the ID and the Password to allow the remote access to your computer.

 

  • To be able to use Remote Maintenance you require an active online connection.
  • During the Remote Maintenance you can see what we do on your computer.
  • With the ID and the Password that you give to our Helpdesk, remote access to your computer will only be possible once.
  • All data, information or other knowledge that our Helpdesk obtains during the Remote Maintenance session, will neither be disclosed on third parties, nor used in any different way by us.
  • The TeamViewer is a product of the TeamViewer GmbH, Jahnstr. 30, 73037 Göppingen, Germany, Phone: +49 (0)7161 60692 50, E-mail: service@teamviewer.com. Further information on the TeamViewer can be found on the website of the manufacturer of TeamViewer. There you can also find all required information on the topic of data security. 
  • Please also read the Notes on Data Protection by the ISD.
  • By contacting our Helpdesk via the Remote Maintenance you confirm that you have read and understood the above notes.

The behaviour of the Combined search function has been modified as of HELiOS 2018 SP2.

If you deactivate all link classes for the search, i.e. nothing has been selected in the field beneath Links, all objects matching the entered search criteria that are not linked to any other object will be shown in the corresponding result list.

In this way you can, for instance, list documents of already deleted articles in conjunction with other, attribute-related search criteria, e.g. in order to link, move or delete them.

Furthermore, you can search for articles without assigned drawing in order to determine for large assemblies whether drawings have been created for all related parts, or whether parts have been "overlooked" by mistake.

Beneath Object-specific on the Result lists tab of the HELiOS Options dialogue window you can find a new pull-down menu item called Document and Article (as of HELiOS 2018 SP2).

This setting is for the Combined search function. It allows you, for instance, to display the result lists of a combined search sorted by document numbers in ascending order by default.

In the result list configuration you can find the new Index up-to-dateness Attribute. If an Article or a Document has a newer index, older indices will be indicated in the Index up-to-dateness column with a star Symbol .

 

Right-clicking the title of the Index up-to-dateness opens a context menu. The menu item Strategy allows you to choose between three different additional display options:

  • Newer index
    The symbol indicates that a newer index exists for the listed object, i.e. that the index of the listed object is not up to date.
  • Newer index (detailed)
    If the object is marked with the symbol, a higher (newer) index exists, but no newer released version of the object. The symbol indicates that higher and released indices exist for the listed object, but that the highest index has not been released yet. If a result list entry is marked with the symbol, this indicates that a version with a higher index with Workflow status Released exists.
  • Newer released index
     If a result list entry in the Index up-to-dateness column is marked with the symbol, this indicates that a higher index with Workflow status Released exists.

Click here for further Information.

 

In the Data function group of the HELiOS Ribbon or in the menu of the active part, you can find the Apply server state function (HiCAD 2018 SP2).

 

The Apply server state function checks whether the currently loaded document or the active document is identical with the current server state. If this is not the case- e.g. because the document has been saved by a different user in the meantime, or exists with a newer index, or because the master data of a linked article have changed or the article exists with a newer index - use this function to apply the current Server state to the document. 

 

As of HELiOS 2018 SP1 an interface to the design review software Autodesk Navisworks can be established.

 

This interface will give you direct access to various HELiOS functions in Navisworks.

As a faster alternative to a function selection via context menu (right-click and choose function), you have now the option to assign buttons to document result lists, allowing you to open documents in the linked application with one mouse click, either for editing or in read- only mode.

For this purpose the two attributes UI_OpenEditItem and UI_OpenItemReadOnly have been created, which just need to be activated in the result list configuration.

 

As of HELiOS 2018 Service Pack 1 these buttons are available in every result list with document context, e.g. in the Document Class Explorer, in the HELiOS Workspace, in the Targets tab of article master masks etc.

 

 

In the directory \HeliosMusterdateien\ of your HELiOS or HiCAD installation you find template files for the different file types of the document input. The template file controls the link between the document and the application (HiCAD, Word, Excel, ...)  

To be able use a central template file directory for multiple workstations, e.g. in order to manage them in one or several central places for different workstations in a department, you can create an .ini file in the local template file directories which refers to these directories (e.g. network drives on Servers etc.). To do this, create a file called  "TemplateExtensions.ini" in the corresponding directories.  The content of the file corresponds to the paths to be considered, e.g.:  

Files located in these folders will then be considered for the HELiOS template file selection dialogue on the local HELiOS workstations. Please ensure that file names are not assigned twice on different directories. If in doubt, clear the local directories for a central managing of the template files.

 

In the product structure of the HELiOS Desktop you have now the option to combine multiple items with identical attribute values into a set on the Utilized items tab. This will then allow you to change the attributes of such combined attributes in one step (as of HELiOS 2018). To combine the items into a set, right-click an item attribute (e.g. Item number or Qty.) and choose Create set.

Items combined into a set will be marked with a “Plus” sign in the first column on the left of the result list. Clicking on the “Plus” sign breaks up the set again, turning the “Plus” sign into a “Minus” sign. Clicking the “Minus” sign creates a set again.

 

As of HELiOS 2018, a direct editing of items that have been combined into a set will be possible. If the attribute values are identical, you can edit them directly and for all items of the set (double-click the set). If the attribute values are not identical, this will be indicated in the result list by the Comment Different values. In this case you must edit the items individually.

 

 Items with different revision indices and different CAD-relevance (i.e. items with CAD link and items without CAD link) cannot be combined into sets. When you attempt to create a set of multiple items only some of which have a CAD link, all items with CAD link and all items without CAD link will be combined into two separate sets.  

 top of page


 

Tips & Tricks 2017

CAD drawings can be converted into other formats via the HELiOS Spooler, e.g. from HiCAD files (.SZA) to STEP or 3D-PDF, from SOLIDWORKS into the .TIF format, or Inventor sheet development files. 

For this you require the hel_fileprint.ini file in the sys directory of your HELiOS or HiCAD installation. This file contains the names of the files to be output as PDF files or to be converted into other file formats.

In the file the two keywords ATTR and FIX can be used: ATTR defines the document attribute to be used for the file name, and FIX defined a fixed text.

Each definition needs to be written in its own row.

 

Example:

ATTR = HEL_DOKUNUMMER

FIX = -

ATTR = HEL_BLATT

FIX = #

ATTR = HEL_INDEX

 

creates a file name consisting of document number, sheet number and index, each of which are separated by a minus sign or a hash, i.e.

[Document number]-[Sheet number]#[Index].

Via the keyword ATTR only document management attributes will be output.

 

Click here for further Information.

If you click on the  Show objects symbol in the Favourites window, you can choose whether the objects in the Favourites window are to be displayed with the index with which they had been added, or with their highest index (if any).

The Concrete index shows the object (Document, Article, Folder, Project) with the index with which it was added to the Favourites.    

The Current state shows the objects with their highest index.  

This allows you to take a look both at the origin of objects that have changed in the meantime and their most recent state in the Favourites window.

The result list for the use of parts or assemblies (parts where-used lists) can now be further refined by means of user-defined filters, allowing you to retrieve relevant part even faster. (as of HELiOS 2017 SP1)
This allows you, for instance, to save search templates that will show you,

  • in which currently released assemblies a particular part with a particular index is directly or indirectly contained, or
  • in which pre-mounted facade parts a particular sealing element has been used throughout different projects.

As is the case with the combined search, article classes and links can be considered. The latter is, for instance, relevant for a filtering for mechatronical items in mechanical engineering or electrical engineering BOMs, since mechanical engineering article are normally linked to a CAD document.

In older HELiOS versions, the UI settings on various workstations could be aligned and standardized by manually copying the corresponding system files to the various systems. The Export/Import mechanism facilitates this process significantly.  

From HELiOS 2017 onwards, changes to the UI of the HELiOS Desktop can be exported as ZIP packages, and re-imported on a different workstation. You can choose which changes are to be exported and imported.

 

Such changes can also be defined and distributed already during installation. In the Extended settings window of the installation mask you have the option to import a UI configuration.

 

Click here for further information.

If interfaces between HELiOS and MS Word, Excel or Outlook have been created, you will find an additional menu called HELiOS in the respective software. It is generally possible to adjust the range of available functions of the HELiOS menu (e.g. deactivate a button). The UI settings for this can be found in the \Recources\Ribbon\OfficeUI\ directory of your HELiOS installation, where the files

  • Ribbon.Document.XML for the settings in Word and Excel, and
  • Ribbon.Explorer.XML for the settings in Outlook 

are located.

To deactivate a function in the UI, rename the switch getEnabled="(...)" beneath the Button ID of the function to enabled="false" in the corresponding system file. For instance, if you want to deactivate the function Attribute fields > New, you need to change the line getEnabled="IsCUrrentDocumentInHelios" to enabled="false" beneath <button id="BtnAttAdd" in the XML file Ribbon.Document.

The function can then no longer be accessed in the Office UI.

Please note:

XML is a Microsoft format that is not treated as a configuration by HELiOS, i.e. it may be overwritten in the course of updates, changing the structure of the relevant files in the process. No warning message will be issued.

In such cases, changes in the files will also be overwritten during HELiOS updates and must be renewed.

Improper modifications can render the HELiOS-Office interface inoperable! If you need any further information, please contact the Consulting team of the ISD.

The selection dialogue for the placing of HELiOS attributes in an Office document has been adjusted to the current HELiOS Desktop standards.

As a result, a wider range of functions of attributes that can be placed in title block is available to you. This also included reference attributes such as the Material ID (Material) or Customer data.

Furthermore, you can use the filter function to search directly for specific attributes.  

Click here for further information.

As of HELiOS 2016 SP2 the Admin Tools tab provides direct access to  

  • the User and Workflow Management EDBSETUP, and
  • the ReleaseNext tool for listing and unlocking of locked documents.

 

  • The Classification functions that were available on the Admin Tools tab of older versions have been removed with the introduction of the new Class Explorers.
  • The Admin Tools tab is only visible if you are logged in as an Administrator.

As of HELiOS 2016 SP2 a conversion of SZA files via the HELiOS Spooler will be possible for the following target formats:  

  • IFC
  • 3D-DXF
  • 3D-DWG
  • ACIS
  • Parasolid
  • Catia V4 and Catia V5
  • ProE
  • VDAFS
  • Iges

The Set-up on the Client takes place in the system file hel_fileconvert.ini.

 top of page


 

Tips & Tricks 2016

The result list filter configuration options for ToDo lists have been enhanced (as of HELiOS 2016 SP2). Here you will find a new option allowing you to display all objects created by the group of the logged-on user (i.e. not only those that were created by the user him-/herself, but also those that were created by other members of his/her group). This will also provide you with an overview of all outstanding tasks of the complete user group.

When creating new article masters in HiCAD, the settings in the file Hicad-HELiOS_TS.dat (in the HiCAD sys directory) will be evaluated. If the parameter 

Apply part attributes to part master when creating new part master? 1=Yes, 0=No

is set to 1, the attributes will be applied as follows: 

Meaning

HiCAD Part attribute

HELiOS article attribute

Article number

$BB  

HEL_SACHNUMMER

Designation 1

$01  

BENENNUNG

Designation 2

$02  

BENENNUNG2

Comment

$03  

BEMERKUNG

Part type

$05  

TEILEART

Dimensions

§09  

ABMESSUNGEN

Length

§03  

LAENGE

Width

§02  

BREITE

Height

§04  

HOEHE

Weight

§01  

GEWICHT

Avoirdupois weight

§18  

HANDELSGEWICHT

Surface area

§10  

FLAECHE

Beam cut type

$06  

PROFIL_SCHNITTTYP

Beam cutting angle1

§14  

PROFIL_SCHNITW1

Beam cutting angle2

§15  

PROFIL_SCHNITW2

Beam cutting angle1   XZ

§05  

PROFIL_SCHNITW1XZ

Beam cutting angle1   YZ

§06  

PROFIL_SCHNITW1YZ

Beam cutting angle2   XZ

§07  

PROFIL_SCHNITW2XZ

Beam cutting angle2   YZ

§08  

PROFIL_SCHNITW2YZ

DIN weight/m

§16  

GEWICHT_M               

Avoirdupois weight/m

§19  

HANDELSGEWICHT_M

Surface area/m

§17  

FLAECHE_M

Moment IY

IY   

MOMENT_IY

Moment WY

WY   

MOMENT_WY

Moment IZ

IZ   

MOMENT_IZ

Moment WZ

WZ   

MOMENT_WZ

A web

ASTEG

PROFIL_ASTEG


If desired, you can also export the HELiOS attributes shown in the ICN when performing an (automatic) 3-D interface export (Step, 3D-PDF) via Plot Manager or the HiCAD Spooler.

For this to happen, you need to adjust the system file brw_3dinterface.hdb in the \sys\ directory of your HiCAD Spooler installation as follows:

 

HDB
# Configuration file for the output of any number of database-
# or HiCAD part attributes instaed of the part name in the 3-D browser.
# TEXT - Commentary ( will not be displayed )
# ATTR - Database attribute
# <D> - Document master data
# <T> - Part master data
# <H> - HiCAD part attribute (e.g. $BB)
# <E> - HiCAD part feature (e.g. NAME)
# _BEGIN_OR_ _END_OR_ - "ODER" link

_BEGIN_OR_
<H>::TEXT=""::ATTR="~vICN"::TYP="WCHAR"::FORMAT="%s"
_END_OR_ 

 

 top of page